Contents

Dynamics 365 for Customer Service - User’s Guide ................................................................. 9

Improve customer service with better automation and tracking ............................................. 9
  Create queue and route cases ............................................................................................ 9
  Automatically create cases from email or social records ...................................................... 9
  Track service levels through SLAs .................................................................................... 9
  Define service terms through entitlements ........................................................................... 10
  Track service agreements and pricing details through contracts ........................................ 10
  Track customer issues through cases .................................................................................. 10
  Share information in the knowledge base .......................................................................... 10
  Create and schedule services ............................................................................................ 11
  Manage performance and productivity through reports and dashboards ............................ 11

Set up customer service ........................................................................................................ 11
  Define service level agreements (Customer Service) ........................................................ 11
  Standard vs. enhanced SLAs: What’s the difference? .......................................................... 12
  Entities (record types) that support SLA ............................................................................ 12
  Create a standard SLA ....................................................................................................... 12
  Create an enhanced SLA .................................................................................................... 16
  Set the SLA as default ........................................................................................................ 20
  Disable the SLA ................................................................................................................ 20
  How is the SLA applied? ..................................................................................................... 20
  Apply SLA on demand ........................................................................................................ 20
  Track SLA status and details on the case record ................................................................. 21

Enable entities for service level agreements ......................................................................... 22
  To enable an entity for SLA .................................................................................................. 22

Add a timer control to the Case form to track time against an SLA ..................................... 23
  Add a timer control to the Case form ................................................................................. 24

Add a timer to forms to track time against enhanced SLAs .................................................. 26
  Enable an entity for SLA .................................................................................................... 27
  Create SLA KPI fields ....................................................................................................... 27
  Create quick view forms for the SLA KPI Instance entity .................................................. 27
    Create a quick view form .................................................................................................. 27
  Create an SLA .................................................................................................................. 29
  Add the quick view form to the primary entity form to show the timer .............................. 29

Create an entitlement to define the support terms for a customer ........................................ 30
  Create an entitlement ........................................................................................................ 30
Add an entitlement channel term ................................................................. 31
Associate a product with the entitlement .................................................... 31
Associate a customer contact with the entitlement ..................................... 32
Activate or deactivate an entitlement .......................................................... 32
Set as default entitlement ........................................................................ 32
Associate entitlements to cases ................................................................. 33
Cancel an entitlement ................................................................................ 33
Renew an entitlement ................................................................................ 33
Create or edit a queue ................................................................................ 33
Create or edit a queue ................................................................................ 33
View queue items ....................................................................................... 34
Additional actions ..................................................................................... 35
Set up queues to manage activities and cases .............................................. 35
Create queues ......................................................................................... 36
Route items to queues .............................................................................. 36
Assign items in the queue to work .............................................................. 36
Define settings for parent and child cases .................................................. 36
Set parent and child case attributes ........................................................... 37
Define status reason transitions for case management ................................ 38
Create rules to automatically route cases ................................................... 40
Create a routing rule set ........................................................................... 40
Apply a routing rule set ............................................................................ 41
Set up rules to automatically create or update records in Dynamics 365 ...... 42
Overview .................................................................................................. 42
Automatically create a case from an email .................................................. 55
Create cases automatically using rules ....................................................... 55
Activate or deactivate a case creation rule ................................................ 58
Manage automatic case creation from a queue form .................................. 58
Create or edit a service ............................................................................. 59
Activate or deactivate a service ................................................................. 60
Add facilities and equipment for service scheduling .................................. 60
Add a facility or equipment ...................................................................... 60
Create or edit a selection rule ................................................................... 61
Create a simple selection rule .................................................................. 61
Create or edit a resource group ................................................................. 62
<table>
<thead>
<tr>
<th>Task</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Create a resource group</td>
<td>62</td>
</tr>
<tr>
<td>Edit a resource group</td>
<td>63</td>
</tr>
<tr>
<td>Use sites to manage your service locations</td>
<td>64</td>
</tr>
<tr>
<td>Set work hours for a resource</td>
<td>64</td>
</tr>
<tr>
<td>Set work hours for a facility or equipment</td>
<td>64</td>
</tr>
<tr>
<td>Set work hours for a user</td>
<td>66</td>
</tr>
<tr>
<td>View, block, or deactivate a social profile</td>
<td>67</td>
</tr>
<tr>
<td>View a social profile</td>
<td>68</td>
</tr>
<tr>
<td>Block a social profile</td>
<td>68</td>
</tr>
<tr>
<td>Deactivate a social profile</td>
<td>68</td>
</tr>
<tr>
<td>Set when your business is closed</td>
<td>68</td>
</tr>
<tr>
<td>Schedule time off</td>
<td>69</td>
</tr>
<tr>
<td>Navigate the service calendar</td>
<td>70</td>
</tr>
<tr>
<td>Legend of colors and statuses</td>
<td>71</td>
</tr>
<tr>
<td>Create a customer service schedule and define the work hours</td>
<td>71</td>
</tr>
<tr>
<td>Create a customer service schedule</td>
<td>71</td>
</tr>
<tr>
<td>Define the work hours for the schedule</td>
<td>72</td>
</tr>
<tr>
<td>Set up a holiday schedule</td>
<td>73</td>
</tr>
<tr>
<td>Configure the process flow for customer service</td>
<td>73</td>
</tr>
<tr>
<td>To change stages, steps, and fields in the customer service process</td>
<td>74</td>
</tr>
<tr>
<td>Create and manage a case</td>
<td>74</td>
</tr>
<tr>
<td>Create a case</td>
<td>75</td>
</tr>
<tr>
<td>Find a solution from similar cases</td>
<td>76</td>
</tr>
<tr>
<td>Resolve a case</td>
<td>77</td>
</tr>
<tr>
<td>Edit a case</td>
<td>77</td>
</tr>
<tr>
<td>Cancel a case</td>
<td>78</td>
</tr>
<tr>
<td>Reassign a case</td>
<td>78</td>
</tr>
<tr>
<td>Add a case to a queue</td>
<td>78</td>
</tr>
<tr>
<td>Save and route a case</td>
<td>79</td>
</tr>
<tr>
<td>Add a phone call, task, email, or appointment activity to a case or record</td>
<td>79</td>
</tr>
<tr>
<td>Add a phone call</td>
<td>80</td>
</tr>
<tr>
<td>Add a task</td>
<td>81</td>
</tr>
<tr>
<td>Add an email</td>
<td>81</td>
</tr>
<tr>
<td>Add an appointment</td>
<td>81</td>
</tr>
<tr>
<td>Add notes</td>
<td>81</td>
</tr>
</tbody>
</table>
Define support terms for customers by using contracts ............................................. 100
Create a service activity without checking for conflicts ............................................. 99
Define support terms for customers by using contracts ............................................. 99
Create contracts ........................................................................................................ 100

Create an activity and associate it with a customer .................................................... 83
Use articles in the knowledge base ............................................................................ 84
Create and update articles ......................................................................................... 84
Edit, reject, or approve an article ................................................................................ 84
Find an article ............................................................................................................. 85
Merge similar cases ..................................................................................................... 85
Create and manage parent and child cases ................................................................. 86
Create a new child case ............................................................................................. 87
Associate a parent case to a child case ...................................................................... 88
Associate a child case to a parent case ...................................................................... 88
Resolve a case with a parent and child relationship .................................................. 88
Find what's assigned to you in a queue ..................................................................... 89
Find the queue items .................................................................................................. 90
Pick an activity or case to work on ............................................................................ 91
Release an item or case that you're working on so someone else can pick it up ............. 92
Route an activity or case to another queue or assign to a different user or team ........... 92
Remove an activity or case from a queue ................................................................... 92
Assign an activity to a user or queue ......................................................................... 92
Assign to another user or team ................................................................................. 92
Add to a queue ......................................................................................................... 92
Basics of service and service scheduling ................................................................... 93
Understand the service terminology ........................................................................ 93
Select resources for service ...................................................................................... 94
Capacity vs. effort—understand the difference ........................................................... 94
Add resources to existing services .......................................................................... 94
Use resource groups ................................................................................................. 95
Test your service ....................................................................................................... 95
Set the capacity required for a service or resource .................................................... 95
Set the capacity of a service ..................................................................................... 95
Set the capacity of a resource .................................................................................. 96
Restrict a resource from performing a service ......................................................... 96
Find the next available time before creating a service activity ................................... 98

Invoice and activate a contract ............................................................................................................. 100
Renew a contract .................................................................................................................................. 100
Create or edit a contract.......................................................................................................................... 100
Create a contract...................................................................................................................................... 100
Add a contract line to a contract ........................................................................................................... 101
Invoice a contract................................................................................................................................. 102
Hold, renew, or release a contract............................................................................................................ 102
Copyright ............................................................................................................................................... 103
Dynamics 365 for Customer Service - User's Guide

Dynamics 365 for Customer Service unifies the way people experience your business, making information available across engagements so your agents offer the consistency and personalization your customers expect. This User's Guide shows you how to set up customer service, and provides training for customer service agents.

Improve customer service with better automation and tracking

Improve customer satisfaction by tracking and recording issues, maintaining service levels, and managing service terms through entitlements in Microsoft Dynamics 365.

Create queue and route cases

You can create queues to sort incoming cases according to subject-matter expertise or product or services to ensure that a customer service representative (CSR) with the right experience gets each case. Use routing rules to automatically route cases that match certain criteria to queues. You can also route individual cases manually. More information: Set up queues to manage activities and cases (Customer Service)

Automatically create cases from email or social records

Save your CSRs from having to manually create cases that come in from email or social records by setting up Microsoft Dynamics 365 to automatically create cases from multiple channels. You can create automatic case creation rules that convert incoming email or social posts targeted to specific queues. For cases that are created from email messages, you can also send a response to the customer with case details by using a default template. More information: Automatically create a case from an email (Customer Service)

Track service levels through SLAs

Service level agreements (SLAs) let you clearly define the timelines in which your customer service or support team is expected to meet the key performance indicators (KPIs) for the service you provide to your customers. You can associate a customer service schedule to the SLA to make sure that your business hours are considered while tracking the SLA timelines.
Help your CSRs see in real time the remaining time or passed time for a KPI on the case records by adding a timer control to the case form.
More information: Define service level agreements (Customer Service)

Define service terms through entitlements
Quickly determine what kind of support a customer is eligible for by defining and associating entitlements with customers. When a customer gets in touch with the support team, this information helps CSRs determine if the customer is eligible for support and whether a case should be created for the customer. You can create an entitlement based on the product that the customer has purchased. You can also have multiple entitlements for a customer. More information: Create an entitlement to define the support terms for a customer (Customer Service)

Track service agreements and pricing details through contracts
Find out if a customer has prepaid support for the products or services they’ve purchased by using contracts in Microsoft Dynamics 365. Use contracts and contract lines to define:
- Prices for the customer service of each product
- Number of calls allowed or the total number of minutes that can be spent on customer issues
- Duration for which the service will be valid
More information: Define support terms for customers by using contracts (Customer Service)

Track customer issues through cases
When a customer contacts your organization, a CSR opens a case and enters information about the customer and the customer's issue.
CSRs can simplify tracking of cases by associating related cases as parent-child cases. For example, a customer reports an issue that needs coordination with other teams. You can create child cases to track the individual work items and assign the cases to the individuals. And, create a parent case to track the progress of the customer-reported case and any communication done with the customer. More information: Define settings for parent and child cases (Customer Service)

If the person who opens the case isn't the one to resolve it, the case can be assigned to a queue or to another CSR. By logging activities and time spent on a case, a manager can track performance and productivity. Open and resolved cases can be searched. A resolved case can be reopened so that additional activities and time can be logged against it, if necessary. More information: Create and manage a case (Customer Service)

Share information in the knowledge base
CSRs can share information, including common issues and the approved fixes, product sheets, and updates, in the form of searchable articles stored in the knowledge base. After a CSR finds the right article, the CSR can email the article directly to the customer and store it with the case for review later. More information: Use articles in the knowledge base (Customer Service)
Create and schedule services

Improve customer satisfaction by defining clearly what services you'll provide to them, and efficiently and optimally scheduling these services. With scheduling, you can provide a service to your customers and ensure that the right combination of personnel, facilities, and equipment are available to perform the service. You can also track a customer's preferences for time of day, service, and personnel.

More information: Create or edit a service (Customer Service) Basics of service and service scheduling (Customer Service)

Manage performance and productivity through reports and dashboards

Reports are an efficient way to stay informed of customer service performance in your organization. With this information, you can create more precise schedules, forecast resource needs, and manage performance improvements.

Microsoft Dynamics 365 introduces new default dashboards for CSRs and customer service managers (CSMs). CSRs can use the dashboard to see their cases with details like:

- Case priority
- Cases close to running over their SLA
- Average handling time

CSMs can use the dashboard to see cases with each CSR (agent) or queue. The CSM can also get insight into whether the SLA for cases was met or not.

Set up customer service

Define service level agreements (Customer Service)

Define the level of service or support that your organization agrees to offer to a customer by using service level agreements (SLAs) in Microsoft Dynamics 365. Include detailed items to define metrics or key performance indicators (KPIs) to attain the service level. KPIs help you get timely warnings on your team's issues while providing support.

You can associate an SLA with an entitlement so that when an entitlement is added to a case, the associated SLA is also applied. You can associate only SLAs that are created for the Case entity with entitlements. More information: Create an entitlement to define the support terms for a customer (Customer Service)

Alternatively, you can set up a default SLA for the organization.

Important

This feature was introduced in CRM Online Spring '14 update and in CRM 2013 Service Pack 1 (on-premises).
Standard vs. enhanced SLAs: What’s the difference?
Microsoft Dynamics 365 lets you create two types of SLAs: Standard and Enhanced. Standard SLAs can only be created for the Case entity. We recommend that you use enhanced SLAs, which have some additional capabilities that standard SLAs don’t have. With an enhanced SLA, you can:

- Create SLAs for entities other than Case.
- Pause an SLA when the case is on hold, so that the time the case is on hold isn’t considered in SLA calculations.
- Add success actions to an SLA. For example, you may want to send communications internally or outside your organization when the SLA has succeeded. Success actions are initiated only when the success condition is met on time, not when it is breached.
- Track SLA statuses and times right on the case form by default. These details are tracked through the SLA KPI Instance record type.

Entities (record types) that support SLA
In previous releases, you could create SLAs only for case records. With CRM, Online 2016 Update 1 and CRM 2016 SP1, you can now create enhanced SLAs for entities that are enabled for SLA. A system administrator or customizer can enable SLAs for the following entities:

- Account
- Contact
- Order
- Invoice
- Quote
- Opportunity
- Lead
- All activity entities like email, phone, and appointment except recurring appointment and its instances

Note
SLA can also be enabled for custom entities and custom activities.
For more information, see Enable entities for service level agreements (Customer Service).

Create a standard SLA
Make sure that you have the Customer Service Manager, System Administrator, or System Customizer security role or equivalent permissions.

When you activate an SLA, a corresponding workflow is also created. For every action you perform on the SLA, you must have permissions to perform the same action on workflows. The SLA is applied in context to the permissions that the owner of the SLA has.
Check your security role

1. Go to **Settings > Service Management**.
2. Go to **Service Level Agreements**.
3. To create a new SLA, on the command bar, click the **New** button.
   - OR-
   To edit an SLA, in the list of records, select the SLA, and then on the command bar, click **Edit**.
4. If you're creating a new SLA, you'll see the **Create SLA** dialog box. Type a name for the SLA, and then in the **Entity** drop-down list, select **Case**.
   You do this because you can create a standard SLA only for the Case entity.
5. Fill in your information:
   - **Applicable From**. Select the case field that specifies the date and time from which the SLA items will be calculated. For example, if you click the **Created-On** field, the calculations for service level agreements will start from the time the case is created.
     - **Note**
     You can have multiple SLA KPIs within one SLA. The start time for different SLA KPIs within an SLA is set at the SLA level and can't be different across SLA KPIs. The start time is determined by the Applicable From field value.

   - **Business Hours**. Select a customer service schedule record that defines your support organization's business hours. This is useful in the SLA time-tracking calculations. If a business hours' record (customer service schedule) isn't selected, the work hours are 24 x 7.
   - **SLA Type**. Select **Standard**.
     You can select **Standard** only when the **Entity** field is set to **Case**.
   - **Allow Pause and Resume**. Select **Do Not Allow**. Because standard SLAs do not support pausing and resuming of SLAs, you can set this field to **Allow** only when you're creating an enhanced SLA.

6. Click **Save**.
7. To add SLA details, in the **SLA Details** section, click the **Add** button.
   You add SLA details to define the key performance indicators (KPIs) or metrics for the service level agreement. You can define any KPI your organization needs. For example, a KPI could be that all cases for standard customers must be resolved within five days of case creation.
   Define success criteria and the failure and warning actions that need to be taken when a service level metric isn’t met for a customer case.

   SLA KPIs are performance indicators that you’d like to track, for example First Response or Resolve By. SLA items refer to SLA KPIs based on specific conditions. You can add multiple SLA items and arrange them in the order that works for you. For any given KPI, only the first SLA item that matches the conditions in the **Applicable When** section is applied.
     - **Note**
In Microsoft Dynamics 365, SLA and SLA KPIs (SLA details) use the process (workflow) functionality. Although SLA KPIs use workflows, not all the actions available in workflows are available for defining the failure and warning actions. The available actions are currently limited to Send Email, Create Record, Update Record, Assign Record, and Change Status. More information: TechNet: Create and edit processes

8. Fill in the information in the New SLA Item form:
   - **Name.** Type a meaningful name.
   - **Related Case Field.** Select a field of DateTime type of the case record that this SLA item refers to. For example, if you are creating a KPI for sending the first response within a specified time, select the First Response By option from the drop-down list. If required, ask your system customizer to create new fields of type DateTime.

   When a case record is created, or updated, in the case record this field is set to the date and time when the failure time will be reached for the respective SLA item. For example, select First Response By in Related Case Field, and set Failure After to 2 hours from case creation. If the case is created at 09:00, the First Response By field in the case record will be set to 11:00, assuming the business hours are 24 x 7.

   **Tip**

   By default, there are four options available in the drop-down list. If you want to track other KPIs, ask your system customizer to create case fields of type date-time.

   - In the Applicable When section, define the conditions under which the KPI will be applicable. The condition can be based on case or related entity fields.
   
   For example, the conditions could be as shown here.

<table>
<thead>
<tr>
<th>Customer [Account]</th>
<th>Category</th>
<th>Equals</th>
<th>Corporate</th>
</tr>
</thead>
<tbody>
<tr>
<td>Case</td>
<td>Priority</td>
<td></td>
<td>High</td>
</tr>
</tbody>
</table>

   **Note**

   If there are multiple clauses, and you don’t use AND or OR grouping, by default the clauses will use the AND grouping.

   - In the Success Criteria section, specify the conditions to define when the KPI will be considered as met. For example, the conditions could be as shown here.
Before you specify the SLA failure and warning actions, save the SLA item record.

- Under **SLA Item Failure**, in the **Failure After** drop-down list, select when the SLA items will be considered as failed. For example, if you select **1 hour**, the KPI will be considered as failed if the first response is not done within 1 hour of case creation. 1 hour is calculated based on the value in date/time field that you select in the **Applicable From** field of the SLA record.

- In the **Failure Actions** section, click **Add Step**, and then specify the actions that will be taken when the success criteria aren't met and the case has exceeded the specified failure time. For example, to mark the case for escalation when the KPI has failed, click **Add Step > Update Record**. Then select **Case** and click **Set Properties**. Now in the case record, change the value of the **Is Escalated** field, and then close the case form.

- Under **SLA Item Warning**, in the **Warn After** drop-down list, select when a warning is to be raised for the KPI nearing violation.

- In the **Warning Actions** section, click **Add Step**, and then specify the actions to be taken when the KPI reaches the warning time. For example, to warn the case owner about the KPI nearing violation, click **Add Step > Send Email**. Then select **Create New Message** and click **Set Properties**. Now in the email record, type the email details, and then close the email form.

**Note**

The time for failure and warning is calculated after considering the business hours selected in the SLA record. If a business hours record (customer service schedule) isn't selected, the work hours are considered to be 24 x 7.

**Important**

Make sure that you don't have too many SLA Items in an SLA, because that can directly impact the create and update operations on the record on which the SLA is applied or re-evaluated. We recommend you not have more than 15 SLA items in an SLA record for performance reasons.

9. Click **Save and Close**.
• The failure and warning actions run asynchronously and may not get triggered exactly at the failure or warning time.
• If the failure or warning times are set to less than 1 hour, processing of failure or warning actions may be delayed.
• Make sure you author the SLAs in a best way suited to your company’s needs. For example, in the SLA Applicable When conditions, avoid using case fields that are updated too frequently, because that may lead to frequent SLA computation and impact performance.

Create an enhanced SLA

Make sure that you have the Customer Service Manager, System Administrator, or System Customizer security role or equivalent permissions.

When you activate an SLA, a corresponding workflow is also created. For every action, you perform on the SLA, you must have permissions to perform the same action on workflows. The SLA is applied in context to the permissions that the owner of the SLA has.

Check your security role

1. Go to Settings > Service Management.
2. Go to Service Level Agreements.
3. To create a new SLA, click the New button.
   -OR-
   To edit an SLA, in the list of records, select the SLA, and then on the command bar, click Edit.
4. If you're creating a new SLA, you'll see the Create SLA dialog box. Type a name for the SLA, and then select the entity for which you want to create the SLA.
5. Fill in your information
   • Applicable From. Select the field that specifies the date and time from which the SLA items will be calculated. For example, if you select the Created On field, the calculations for service level agreements will start from the time the record is created.

   ✔ Note

   You can have multiple SLA KPIs within one SLA. The start time for different SLA KPIs within an SLA is set at the SLA level and can't be different across SLA KPIs. The start time is determined by the Applicable From field value.

   • Business Hours. Select a customer service schedule record that defines your support organization’s business hours. This is useful in the SLA time-tracking calculations. If a business hours record (customer service schedule) isn't selected, the work hours are considered to be 24 x 7.
   • SLA Type. Select Enhanced.
If you're creating a SLA for an entity other than Case, this field is automatically set to Enhanced, and can't be changed.

- **Allow Pause and Resume.** Select **Allow** if you want the SLA to pause during the time the record is on hold. For each entity that's enabled for SLA, you can set the statuses that will be considered "on hold" in the Service tab of System Settings dialog box. You can set this field to **Allow** only when you're creating an enhanced SLA.

6. Click **Save**.

7. To add SLA details, in the **SLA Details** section, click the **Add** button.

8. Fill in your information in the SLA Item form:
   - **Name.** Type a meaningful name.
   - **SLA KPI.** Select the key performance indicator the SLA item is about. For example, if you are creating a KPI for sending the first response within a specified time, select the **First Response By KPI** option from the drop-down list.
     For example, select **First Response By KPI** in the SLA KPI field, and set **Failure After** to 2 hours from record creation. If the record is created at 09:00, the **Failure Time** field of the SLA KPI Instance record is set to 11:00 assuming the business hours are 24 x 7.

   **Tip**
   If you're creating an SLA for a Case entity, by default, there are two options available in the drop-down list. If you want to track other KPIs for Case or if you're creating the SLA for entities other than Case, ask your system customizer to create new fields (of type lookup) that refer to the SLA KPI Instance entity.

   - In the **Applicable When** section, define the conditions under which the KPI will be applicable. The condition can be based on primary entity or related entity fields.
     For example, the conditions could be as follows.

<table>
<thead>
<tr>
<th>Customer (Account)</th>
<th>Category</th>
<th>Equals</th>
<th>Corporate</th>
</tr>
</thead>
<tbody>
<tr>
<td>Case</td>
<td>Priority</td>
<td>Equals</td>
<td>High</td>
</tr>
</tbody>
</table>

   - In the **Success Criteria** section, specify the conditions to define when the KPI will be considered as met. For example, the conditions could be as follows.
Before you specify the SLA failure and warning details, save the SLA item record.

- In the **Success Action** section, click **Add Step**, and then specify the actions that you want Dynamics 365 to take when the success criteria is met before the violation time. For example, click **Add Step > Change Status**. Then, in the first drop-down list, select **Case**, and in the next drop-down list, select **Information Provided**. This option is available only if you're creating enhanced SLAs.

- Under **SLA Item Failure**, in the **Failure After** drop-down list, select when the SLA items will be considered as failed. For example, if you select **1 hour**, the KPI will be considered as failed if the first response is not done within 1 hour of case creation. 1 hour is calculated based on the value in date/time field that you select in the **Applicable From** field of the SLA record.

- In the **Failure Actions** section, click **Add Step**, and then specify the actions that will be taken when the success criteria are not met and the record has exceeded the specified failure time. For example, to mark a case for escalation when the KPI has failed, click **Add Step > Update Record**. Then select **Case** and click **Set Properties**. Now in the case record, change the value of the **Is Escalated** field, and then close the case form.

- Under **SLA Item Warning**, in the **Warn After** drop-down list, select when a warning is to be raised for the KPI nearing violation.

- In the **Warning Actions** section, click **Add Step**, and then specify the actions to be taken when the KPI reaches the warning time. For example, to warn the case owner about the KPI nearing violation, click **Add Step > Send Email**. Then select **Create New Message** and click **Set Properties**. In the email record, specify the email details, and then close the email form.

- **Note**

  The time for failure and warning is calculated after considering the business hours selected in the SLA record. If a business hours record (customer service schedule) isn't selected, the work hours are considered to be 24 x 7.

To help you get started with creating SLAs for other entities, here are a couple of sample SLA KPIs for the lead entity.

**SLA KPI 1**: Contact the customer (tracks if the salesperson has contacted the customer within the specific timeline)
<table>
<thead>
<tr>
<th>Applicable when</th>
<th>Success condition</th>
<th>Failure time</th>
<th>Failure action</th>
<th>Warning time</th>
<th>Warning action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Rating = Hot</td>
<td>Status = Contacted</td>
<td>1 day</td>
<td>Send an escalation email to the sales manager</td>
<td>16 hours</td>
<td>Send a warning email to the salesperson</td>
</tr>
<tr>
<td>Rating = Warm</td>
<td>Status = Contacted</td>
<td>2 days</td>
<td>Send an escalation email to the sales manager</td>
<td>1.5 days</td>
<td>Send a warning email to the salesperson</td>
</tr>
<tr>
<td>Default</td>
<td>Status = Contacted</td>
<td>7 days</td>
<td>Send an escalation email to the sales manager</td>
<td>5 days</td>
<td>Send a warning email to the salesperson</td>
</tr>
</tbody>
</table>

SLA KPI 2: Action on lead (tracks if the salesperson has taken necessary action on the lead within specific timeline)

<table>
<thead>
<tr>
<th>Applicable when</th>
<th>Success condition</th>
<th>Failure time</th>
<th>Failure action</th>
<th>Warning time</th>
<th>Warning action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Rating = Hot</td>
<td>Status = Qualified or Disqualified</td>
<td>2 days</td>
<td>Send an escalation email to the sales manager</td>
<td>1.5 hours</td>
<td>Send a warning email to the salesperson</td>
</tr>
<tr>
<td>Rating = Warm</td>
<td>Status = Qualified or Disqualified</td>
<td>5 days</td>
<td>Send an escalation email to the sales manager</td>
<td>4 days</td>
<td>Send a warning email to the salesperson</td>
</tr>
<tr>
<td>Default</td>
<td>Status = Qualified or Disqualified</td>
<td>15 days</td>
<td>Send an escalation email to the sales manager</td>
<td>12 days</td>
<td>Send a warning email to the salesperson</td>
</tr>
</tbody>
</table>

**Important**

- We do not recommend creating or updating SLAs by using Dynamics 365 for Outlook. Use the Dynamics 365 web application for this purpose.
- Make sure that you don’t have too many SLA Items in an SLA, because that can directly impact the create and update operations on the record on which the SLA is applied or re-evaluated. We recommend you not have more than 15 SLA Items in an SLA record for performance reasons.
Set the SLA as default
For case entity, make an SLA a default one if you want it to apply to all the cases that don't have an SLA applied through an entitlement. This is useful when a customer wants a service level agreement without an entitlement.
For all other entities, select a default SLA. You can have one default SLA for each entity that is enabled for SLA.
To set an SLA as the default, select an active SLA from the list, and then click Set as Default on the command bar.

Note
If you deactivate a default SLA, you must activate it again before resetting it as the default.

Disable the SLA
During maintenance activities or when you're importing records and you don't want the SLAs to apply, you can disable SLAs for the organization. A system administrator can disable SLAs from the System Settings.

How is the SLA applied?
When a record is created, the SLA is applied (default or through entitlement for the Case entity) and the related record field values are updated. When the record is modified and any of the record field values change, that is, when the fields that are added in the Applicable When conditions of the SLA change, the SLA is applied again. For example, if the priority of the case changes from Normal to High, and according to the SLA the first response should happen soon, the SLA is reapplied to make sure the KPIs are tracked based on the updated values.
When the SLA is applied again, all the SLA items are evaluated based on the updated record fields and the failure or warning actions are initiated if the time has been exceeded. This happens even if the failure or warning actions were already initiated before the record was updated. To avoid this, you can request that your system customizer add a custom field to the entity (to track if the failure/warning actions were already taken) and add it to the Applicable When condition so that the actions aren't initiated multiple times.

Note
You can only have one SLA running on one record. When an entity record is updated with a different SLA, the previously applied SLA is canceled.

Apply SLA on demand
With the enhancements made to SLAs, you can now apply SLAs to records manually. You can also automatically apply SLAs to records based on your business logic (using workflows or custom plug-ins).
For example, if your customers are spread across geographies, you can have multiple SLAs with different business hours and holiday schedules for different geographies. You can set up business logic
to apply SLAs on case records based on the customer’s region to make sure that the SLA time calculation happens based on the correct geography.

To create workflows so SLAs are automatically applied, talk to your customer service managers, administrator, or customizer. More information: TechNet: Workflow processes

To apply SLAs on-demand manually, choose the SLA in the SLA field. This field is not available by default on entity forms. Ask your system administrator to add the field on the entity form.

**Track SLA status and details on the case record**

The CSR working on a case can see the SLA details right on the case form.

The following table explains what happens when a standard or enhanced SLA applies to a case form.

<table>
<thead>
<tr>
<th>Case form with standard SLA applied</th>
<th>Case form with enhanced SLA applied</th>
</tr>
</thead>
<tbody>
<tr>
<td>Only the failure time is tracked and saved on the case record. You can ask your system administrator or customizer to add a timer to the case form. The timer shows the time remaining to meet the SLA or the time elapsed since the SLA failed. More information: Add a timer control to the Case form to track time against an SLA (Customer Service).</td>
<td>When an enhanced SLA is applied to a case, a related SLA KPI Instance record is created for each SLA KPI that is tracked for that case. In the Enhanced SLA Details section of the case record, you'll see a timer and the SLA KPI instances for the case with their statuses and failure and warning times. When a service rep puts a case on hold, the status of the SLA KPI Instance is set to Paused. You can see the time for which a case was on hold and the last time the case was put on hold. These details are not available on the case form by default, but your system customizer can add these fields on the case form for you. The on hold time is the time for which the case was set to a status that you defined as an On-Hold status in the System settings dialog box. When the service rep resumes a case, the status of the SLA KPI Instance record is updated. The following details are updated in the record if the SLA isn't violated: • Failure time • Warning time • Total time the case is on hold If the service rep puts the case on hold after the warning time, then the warning time isn't updated when the case is resumed.</td>
</tr>
</tbody>
</table>

**Important**

To track SLAs for entities other than case, ask your system administrator or customizer to add an enhanced SLA timer on the entity forms. More information: Add a timer to forms to track time against enhanced SLAs (Customer Service)
Enable entities for service level agreements

Service level agreements are not just important in the customer service space, but also for sales and marketing to ensure efficient handling of leads from start to finish. Previously, you could only create SLAs for case records. With Microsoft Dynamics CRM Online 2016 Update 1 and Microsoft Dynamics CRM 2016 Service Pack 1, you can now enable any of these entities for SLA:

- Account
- Contact
- Order
- Invoice
- Quote
- Opportunity
- Lead
- All activity entities like email, phone, and appointment, except recurring appointment and its instances.

SLAs can also be enabled for custom entities and custom activities.

Important

Only enhanced SLAs can be created for other entities. A standard SLA can be created only for the Case entity.

To enable an entity for SLA

Make sure that you have the System Administrator or System Customizer security role or equivalent permissions.

1. Go to Settings > Customizations.
2. Click Customize the System.
3. In the solution explorer, in the left nav pane, click the entity that you want to enable for SLA.
4. Under Communication & Collaboration, select the Enable for SLA check box.
5. Click Save.
6. Click Publish.

Note

- The maximum number of entities that can have active SLAs for your organization is 7.
- The maximum number of SLA KPIs allowed per entity for your organization is 5.
Add a timer control to the Case form to track time against an SLA

Add a timer control to an entity form to help users gauge the amount of time they have to complete a task—typically as specified in a service level agreement (SLA). The timer control initially displays a count-down timer to show the time remaining to complete the task.

On a case form, the timer control can show any of the following, depending on the actions of the customer service representative (CSR) and what you specify when you set up the timer control:

- If the CSR completes the task within the time remaining, the control shows the word **Succeeded**.
- If the CSR doesn’t complete the task within the time remaining, the control shows the word **Expired**.
- As the timer counts down, the color changes to yellow as the time remaining nears non-compliance. If the time remaining expires, the timer shows the word **Expired**. Then the timer color changes to red and the timer starts counting up to show the elapsed time since the task should have been completed. This behavior is optional.
- If a condition causes the milestone to be canceled, the control shows the word **Canceled**. This behavior is optional.
- If either of the required fields in the **Timer Control** dialog box do not have a value in the record, the control shows the words **Not Set**.

---

**Important**

- The instructions in this topic apply if you're adding a timer to track time for the date/time field of any entity, or for tracking time against standard SLAs on case records. If you are using enhanced SLAs and want to add a timer to your forms, see Add a timer to forms to track time against enhanced SLAs (Customer Service).
• The timer control is designed to visually show the current state or show the remaining or elapsed time relative to the date and time as specified in the Failure Time field of the SLA KPI Instance. It doesn’t calculate or keep track of the time for which the Pause condition is true.

Add a timer control to the Case form

Make sure that you have the System Administrator or System Customizer security role or equivalent permissions.

1. Go to Settings > Customizations.
2. Click Customize the System.
3. In the solution explorer, in the left nav pane, expand Entities, expand the Case entity, click Forms, and then open the Case form of type Main.
   To add the timer to the interactive experience form so the customer service representatives can use it in the interactive service hub, open the case form of type Main – Interactive experience.
4. Click on the form where you want to place the control. You can add it anywhere except the form header or footer.
5. On the Insert tab, in the Control group, click Timer.

   In the Timer Control dialog box:

   a. In the General section, type a name and label for the control.
   b. Under Data Source, next to Failure Time Field, select the date-time field that represents the time when a milestone should be completed. For example, select the First Response By field.
   c. Next to Success Condition, select a field to use to evaluate the success of the milestone, and then select the condition that indicates success. For example, select the First Response Sent field, and then select Yes to indicate the success criteria of the First Response metric. This setting is required.
   d. Next to Failure Condition, select a field to use to evaluate the failure of the milestone, and then select the condition that indicates the failure. For example, in the first drop-down list, select Is Escalated. In the second drop-down list, select Yes.
e. Next to **Warning Condition**, enter the condition that will cause the timer control to display a warning when the time is about to expire. For example, in the first list next to **Warning Condition**, select **First Response SLA Status**. In the list to the right, select **Nearing Noncompliance**. This setting is optional.

f. Next to **Cancel Condition**, select a field to evaluate whether the achievement of the milestone should be canceled. Then choose the option that indicates the milestone is canceled. This setting is optional.

g. Next to **Pause Condition**, enter the condition that will cause the timer to pause the countdown. For example, you want the timer to pause the countdown every time the case status is set to “On-hold”. For this, in the first drop-down list, select **Status**. In the second drop-down list, select **On-hold**.

![Timer Control](image)

Set the properties of the timer control.

<table>
<thead>
<tr>
<th>General</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Name <strong>Specify a unique name.</strong></td>
<td></td>
</tr>
<tr>
<td>Name *</td>
<td>First_Response_Timer</td>
</tr>
<tr>
<td>Label *</td>
<td>First_Response_By</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Data Source</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Specify the data source for failure time, and the conditions for this timer control.</strong></td>
<td></td>
</tr>
<tr>
<td>Failure Time Field *</td>
<td>First_Response_By</td>
</tr>
<tr>
<td>Success Condition *</td>
<td>First_Response_Sent Yes</td>
</tr>
<tr>
<td>Failure Condition</td>
<td>First_Response_Sent No</td>
</tr>
<tr>
<td>Warning Condition</td>
<td>First_Response_SLA_Status Nearing_Noncompliance</td>
</tr>
<tr>
<td>Cancel Condition</td>
<td>Status Canceled</td>
</tr>
<tr>
<td>Pause Condition</td>
<td>Status_Reason On_Hold</td>
</tr>
</tbody>
</table>

6. Click **OK** to add the control to the form.
Notes

- The timer control refreshes on the Unchanged form event, and also when the form is loaded.
- You can add a timer control to a form based on any record type (entity), including custom record types.
- You can add multiple timer controls for different key performance indicators (KPIs).
- You can add a timer control to any Main or Main - Interactive experience form of other entities, but timer controls are not displayed in Microsoft Dynamics 365 for tablets.

Add a timer to forms to track time against enhanced SLAs

A timer helps users gauge the amount of time they have to complete a key performance indicator (KPI) that is typically associated with a service level agreement (SLA). If your organization uses enhanced SLAs, you must use quick view forms to add a timer to track time against such SLAs.

The timer control initially displays a count-down timer to show the time remaining to complete the KPI.

Note

- A timer control can be used independent of SLAs, too.
- The timer control is designed to visually show the current state or show the remaining or elapsed time relative to the date and time specified in the Failure Time field of the SLA KPI instance. It doesn’t calculate or keep track of the time for which the Pause condition is true.

The timer control can show any of the following, depending on the actions of the user and what you as a system administrator or customizer specify when you set up the timer control:

- If the user completes the task within the time remaining, the control shows the word Succeeded.
- If the user doesn’t complete the task within the time remaining, the control shows the word Expired.
- As the timer counts down, the color changes to yellow as the time remaining nears non-compliance. If the time remaining expires, the timer shows the word Expired. Then the timer color changes to red and the timer starts counting up to show the elapsed time since the task should have been completed.
- If a condition causes the SLA KPI to pause, the control shows the word Paused.
- If a condition causes the SLA KPI to be canceled, the control shows the word Canceled. This behavior is optional.
- If either of the required fields in the Timer Control dialog box do not have a value in the record, the control shows the words Not Set.
There are a few steps to follow to add a timer to track time against enhanced SLAs:
1. Ensure the entity is enabled for SLA.
2. Create SLA KPI fields for the entity for which you want to create the SLA.
3. Create quick view forms for each SLA KPI instance field that you've created.
4. Create an SLA.
5. Add the quick view forms that you created to the primary entity form

Enable an entity for SLA
To add a timer for an enhanced SLA to an entity form, that entity must be enabled for SLA. To learn more, see Enable entities for service level agreements.

Create SLA KPI fields
Make sure you have the System Administrator security role or equivalent permissions in Microsoft Dynamics 365.
1. Go to Settings > Customizations.
2. Choose Customize the System.
3. Under Components, expand Entities, and then expand the entity you want.
4. Click Fields.
5. On the Actions toolbar, click New, and then enter a Display Name to generate the Name.
6. In the Data Type drop-down list, select Lookup.
7. In the Target Record Type drop-down list, select a SLA KPI Instance.
   If you create a lookup field in an entity form, the relationship is automatically generated. A lookup field is created as a relationship field.
8. Click Save and Close to close the form editor.
9. Publish your customization.
   • To publish customizations for just one entity, under Components, click Entities. Then, on the Actions toolbar, click Publish.
   • To publish all customizations, you have made to any entities or components, on the Actions toolbar, click Publish All Customizations.

Create quick view forms for the SLA KPI Instance entity
Quick view forms help you show data of a related entity in the primary entity form. For enhanced SLAs, all the SLA-related states and times are stored in the SLA KPI instance entity. To show this data in the primary entity like a lead or an opportunity form, you must create a quick view form for each SLA KPI field that you've created for the primary entity. Add a timer to the quick view form so it shows the count down for the SLA.
Create a quick view form

1. Go to Settings > Customizations.
2. Choose Customizations, then choose Customize the System.
3. In the solutions explorer, expand the SLA KPI Instance entity, and then select Forms.
4. Select New > Quick View Form from the tool bar.
5. In the Form group, click Form Properties, and then specify a form name.
6. Double-click the section, type a meaningful name for the section, and then click OK.
7. Select the section, and on the Insert tab, click Timer.
8. Specify a name and label for the timer, and the data source for the failure time.

Following is an example of the properties you'd set for a timer for a Case entity.

Note

Typically, for enhanced SLAs, the timer control is set up using the SLA KPI Instance status field values only.
Create an SLA

Create an SLA for the entity you want to track. For example, you may want to create track the time taken by sales person to take action on a lead, like qualifying or disqualifying a lead. For this, create an SLA for the lead entity. For more information on creating an SLA, see Define service level agreements.

Add the quick view form to the primary entity form to show the timer

You can add the quick view forms you created earlier as quick view controls in the primary entity forms. Make sure that you have the System Administrator or System Customizer security role or equivalent permissions.

1. Go to Settings > Customizations.
2. Click Customize the System.
3. In the solution explorer, in the left nav pane, expand Entities, expand the entity you want to add the quick view form to, and then click Forms.
4. To add the timer to use in the Microsoft Dynamics 365, open the form of type Main.
   -OR-
   To add the timer to the interactive experience form so users can use it in the interactive service hub, open the form of type Main – Interactive experience.
5. Add a section to insert the quick view control. On the Insert tab, in the Section group, click Section, and then click One Column. Double-click the section to specify the section properties. More information: TechNet: Use the form editor or TechNet: Use the Main - Interactive experience form and its components.

Note

You can't add an SLA timer to the reference panel section of the Main - Interactive experience form.

6. Select the section that you just added, and on the Insert tab, in the Control group, click Quick View Form.
7. Specify a name and label for the quick view control.
8. In the Lookup Field drop-down list, select the lookup field that you created to point to the SLA KPI Instance entity.
9. The Related Entity drop-down list will be automatically set to “SLA KPI Instance”.
10. In the Quick View Form drop-down list, select the quick view form you created in the SLA KPI Instance entity.
11. Click OK to close the Quick View Control Properties dialog box.
Create an entitlement to define the support terms for a customer

Define what kind of support your customers are eligible for by creating entitlements in Microsoft Dynamics 365. With entitlements, you specify the support term based on number of hours or number of cases. The customer’s support level can vary based on the product or service that the customer has purchased. Customers who’ve purchased different products can be entitled to different support levels. This information helps the customer support agents verify what the customers are eligible for and create cases for them accordingly.

Note
This feature was introduced in CRM Online Spring ‘14 update and in CRM 2013 Service Pack 1 (on-premises).

Create an entitlement

Make sure that you have the Customer Service Manager, System Administrator, or System Customizer security role or equivalent permissions.

1. Go to Settings > Service Management.
2. Choose Entitlements.
3. To create a new entitlement from a template, click + New > From Template. In the Select Template dialog box, click the entitlement template, and click Select.
   -OR-
   To create a new entitlement from scratch, click + New > Blank Entitlement.
   -OR-
   To edit an entitlement, in the list of records, click the entitlement, and then on the command bar, click Edit.
4. Fill in your information. Use the handy tooltips as a guide.
   - Name. Give the entitlement a meaningful name.
   - Primary Customer. Choose the customer you’re creating this entitlement for.
   - Start Date. Choose the date from which the customer will be entitled for support.
   - End Date. Choose the date after which the customer will no longer be entitled for support.
   - Restrict based on entitlement terms. To make sure no cases are created when the entitlement term is over, click Yes. When you choose Yes, a customer service agent won’t be able to create a case when Remaining Terms is fewer than zero OR when the term remaining for a channel is less than zero.
   - SLA. Choose a service level agreement (SLA) record to associate the service levels or key performance indicators for the support you’re providing with this entitlement.

Under Entitlement Terms, specify the term details for the entitlement:
   - Allocation Type. Choose whether the entitlement is for number of hours or number of cases.
- **Decrease Remaining On.** Choose whether to decrease the remaining term on case creation or resolution. If you decrease the remaining term based on case creation:
  - Creating or updating a case with the associated entitlement decreases entitlement terms
  - Canceling a case with the associated entitlement increases entitlement terms
  - Reactivating a canceled case with the associated entitlement decreases the entitlement terms.
  
  If you decrease the remaining term based on case resolution:
  - Resolving a case with the associated entitlement decreases the entitlement terms
  - Reactivating a resolved case with the associated entitlement increases the entitlement terms.

- **Total Term.** Specify the total amount of support the customer is entitled for with respect to the allocation type. For example, if the allocation type is number of cases and you specify 100 in **Total Term,** the customer is entitled for support up to 100 cases.
  - The **Remaining Term** shows the total number of hours or cases remaining for the customer's entitlement. The value decrements every time a case is created or resolved (depending on what you select in **Decrease Remaining On**) against the entitlement.

5. Click **Save.**

**Add an entitlement channel term**

The **Entitlement Channel** section specifies the support channel through which the customer can reach the organization and seek support.

Use this section to define the channels your customers are entitled to, and track the customer support term for each channel. For example, you can add phone and email as the channels through which you'll offer support. If you want to restrict support through the phone channel to 80 hours and email to 20 hours, create individual entitlement channel records and add their total terms.

**Note**

You must save the entitlement record before you can add entitlement channels to an entitlement.

1. In the **Entitlement Channel** section, click **+.**
2. Specify the total terms that you want to allot to the particular channel.
   - The remaining term is auto-calculated and shows the total number of hours or cases remaining for the customer's entitlement.

**Associate a product with the entitlement**

If you want the entitlement to apply to a specific product for a customer, associate the product to the entitlement.

**Note**

If you don't add a product, the customer will be entitled to support for all the products.
1. While in the entitlement record, in the **Products** section, click +.

2. In the **Search** box, type the first few letters of the name of the product that you want to associate with the entitlement.
   
   If a product isn't available, click + **New** to create a new one.

**Associate a customer contact with the entitlement**

To let only certain contacts of a customer claim the entitlement for a specific product, associate the contacts with the entitlement.

**Note**

If you don't add a contact, all the contacts for the specified primary customer will be entitled to support.

1. While in the entitlement record, in the **Contacts** section, click +.

2. In the **Search** box, type the first few letters of the contact that you want to associate with the entitlement. This contact record must belong to the account or contact specified in the **Customer** field.
   
   If a contact isn't available, click + **New** to create a new contact record.

All active entitlements for a customer appear in the **Active Entitlements** section of the customer record.

**Activate or deactivate an entitlement**

Before you can start applying an entitlement to a case, you must activate it.

1. While in the entitlement record, on the command bar, click **Activate**.

2. In the **Confirm Activation** dialog box, click **Activate**.

**Note**

If the start and end date of the entitlement fall in the future, the status of the entitlement is set to **Waiting**. On the start date, the status automatically changes to **Active**. If the end date is in the past, the entitlement is set to **Expired**.

When an entitlement is active, you can't edit it. To deactivate an entitlement so you can edit it, on the command bar, click **Deactivate**.

**Set as default entitlement**

If you're on Microsoft Dynamics CRM Online 2015 Update 1 or later, you can activate the entitlement and then set it as the default entitlement for a customer. The entitlement terms from the associated
entitlement are automatically decremented. However, if you don't want the entitlement terms to be
decremented for a case, click Do not decrement entitlement terms on the command bar.
1. On the command bar, click Set As Default.
2. In the Confirm set default dialog box, click OK.

**Associate entitlements to cases**

In a case record, in the Entitlement field, click the Lookup button, and select an entitlement. The inline
lookup shows only the active entitlement for the customer of the case.
The Entitlements section in the case record lists all the active entitlements for the customer. More
information: Create and manage a case

**Cancel an entitlement**

If the entitlement is no longer valid, you can cancel it. To cancel an active or waiting entitlement, open
the entitlement, and on the command bar, click Cancel.

**Renew an entitlement**

To renew a canceled or expired entitlement, open the entitlement, and then on the command bar, click Renew.
The current entitlement will be set to Closed and a new entitlement will be created.
The start date of this new entitlement is set to the current date and the end date is set to the current
date plus the number of days between the end date and start date. The data in other fields is copied
from the old entitlement.

**Create or edit a queue**

Make sure that activities or unresolved cases are acted upon faster by using queues in Microsoft
Dynamics 365.

Queues can be useful in:
- Having a centralized list of pending work that needs attention
- Sorting tasks by type or by the people assigned to complete them

Use queues to categorize and prioritize your activities and cases. You can categorize based on:
- Different products or services
- Different subscription levels (regular, premium customers)
- Various activity categories
- Different geography
Tip
You can use an Office 365 shared mailbox when you create a queue in Dynamics 365 and not consume an Office 365 license for a forwarding email account.
See Blog: CRM Queue with an Office 365 Shared Mailbox

Create or edit a queue
Make sure that you have the Sales or Marketing Manager, Customer Service Manager, System Administrator, or System Customizer security role or equivalent permissions.

1. Go to Settings > Service Management or Business Management.
2. Choose Queues.
3. To create a new queue, click New.
   - OR -
   To edit a queue, in the list of queues, click the queue, and then on the command bar, click Edit.
4. Type or change information in the text boxes.
   Hover tips provide hints about what to enter.
   • In the Summary section, complete the required fields.
   • In the Name field, type the name of the queue.
   • In the Type field, choose if the queue is a private or public queue. You can use a private queue to allow only a specific set of people to work on activities in this queue.
     If you're creating a private queue, you'll need to add members to this queue manually. In the Members section, click the Add button + to add members to the queue. Only these members will be able to work on the items in this queue.

  Note
The email address you enter in the Incoming Email field receives all messages sent to the queue.

• In the Email Settings section, in the Convert to email activities drop-down list, choose which messages to track as activities.
• In the Mailbox field, a mailbox record for the queue is automatically created and selected as soon as you save the queue record. To update the mailbox details, click the mailbox name.
  More information: TechNet: Create forward mailboxes or edit mailboxes
• In the Record creation and update rules section, add a Record Creation and Update Rule record. By using these rules, you can automatically create or update system or custom records from incoming Dynamics 365 activities, such as emails, social activities, or custom activities.
  More information: Set up rules to automatically create or update records in Dynamics 365
This feature was introduced in CRM Online 2015 Update 1 and CRM 2016 (on-premises).

Interested in getting this feature? Find your Dynamics 365 administrator or support person

Important

This is a central place to manage rules across all supported activities including out-of-the-box and custom activities associated with the queue.

The Record creation and update rules section displays rules that have been created in CRM Online 2015 Update 1, using the Email Activity Conversation Setting or Social Activity Conversation Setting and that have the same queue ID as the queue.

If you used Email to Case or Social to Case rules from earlier versions, such as CRM Online Spring ’14 or CRM 2013 Service Pack 1 (on-premises), then you will be able to see your rules in this section when you upgrade to CRM Online 2015 Update 1.

Multiple rules with the same source type and same queue can exist. Therefore, when you click Email Activity Conversation Settings or Social Activity Conversation Settings, the rule with the latest Last Modified On date is applied.

5. Click Save.

View queue items

In the Queue Items section, all activities that are either routed to this queue automatically by the routing rules or the activities that are manually assigned to this queue will be listed here.

Additional actions

To create records for this queue, on the command bar, click Email Activity Conversation Settings or Social Activity Conversation Settings.

More information: Set up rules to automatically create or update records in Dynamics 365 or Automatically create a case from an email

Set up queues to manage activities and cases

Use queues to organize, prioritize, and monitor the progress of your work. In Microsoft Dynamics 365, queues are containers used to store anything that needs to be completed or requires an action, for example completing a task or closing a case.

Note

For Dynamics 365 (online) organizations, the private and public queues or automatic case creation functionality is available only in organizations that have applied product updates for CRM Online Spring ’14 or later or have installed the CRM Online 2015 Update or later. For Dynamics 365 on-premises organizations, these features are available if they have installed CRM 2013 Service Pack 1 (on-premises) or later, or have updated to CRM 2015 or later. Interested in getting this feature? More information: Find your Dynamics 365 administrator or support person
Create queues

By default, a queue is created for each user and team in Microsoft Dynamics 365. You can use this default queue to track all your work items, or you can set up queues to reflect your organization's structure, business processes, or both. How you set up queues depends on how your business works. For example, you could create separate queues for First Tier and Second Tier product support teams that reflect their differing levels of expertise, or Gold and Silver queues to reflect differing priorities based on service contracts that customers have with your organization.

Microsoft Dynamics 365 lets you create two types of queues: private or public. Create private queues with limited sets of members to let only those members view the items in the queue. Create public queues to let everyone in the organization view the items in a queue.

Route items to queues

For all cases that are automatically created from incoming email and social posts, create routing rules to route the cases to queues. Then assign the items in the queue to appropriate CSRs or users. Alternatively, you can manually add cases and activities to queues.

Assign items in the queue to work

Queues share cases or activities as a group until these are taken out of the queue, or accepted, by a customer service representative (CSR) who assumes responsibility for handling them. CSRs can pick the items for themselves, or a customer service manager (CSM) can manually route these cases to the CSRs or to other queues, users, or teams.

Define settings for parent and child cases

In Microsoft Dynamics 365, you can track multiple issues for a customer, or track the same issue that's affecting multiple customers, using parent and child cases. For example, you could track a case where work needs to be done by other departments. The primary case or issue is called the parent case. Any related cases are called a child cases. Before your service team can start using this feature, you'll need to go into the settings area and set up a few rules about how information will be inherited.

Important

This feature was introduced in CRM Online Spring '14 update and in CRM 2013 Service Pack 1 (on-premises).
Set parent and child case attributes

Follow the steps for the app you're using.

If using the Dynamics 365 web application
a. On the nav bar, choose Microsoft Dynamics 365 > Settings.
b. Choose Settings > Service Management.

If using Dynamics 365 for Outlook
a. In the Navigation Pane, choose Settings > Business > Service Management.

1. Click Parent and Child case settings.
2. On the Case Settings dialog box, select the attributes that the child case will be inherit from the parent case.
3. Using the Parent and Child case settings, specify the information that will be inherited from a parent case to the child case. You can also select a case closure setting that defines how parent and child cases are closed. Select one of the case closure preference for parent and child cases:
   - **Close all child cases when parent case is closed**: The parent case can't be closed until all the child cases are closed.
   - **Don't allow parent case closure until all child cases are closed**: The parent case can't be closed until all the child cases are closed.

   **Note**
   If you don't make a selection, parent and child cases are closed independently of each other. This is the default setting.

4. When you're done, click OK.
Define status reason transitions for case management

There’s new capability to specify status reason transitions for the Case record type (entity) or custom record types.

**Important**

This feature was introduced in CRM Online Spring ’14 update and in CRM 2013 Service Pack 1 (on-premises).

If you’re in charge of incident management for an organization, it’s important to provide a simple model for customer service representatives responsible for entering and updating case status. In Dynamics 365, there are two fields that work together to provide information about case status: the Status field and the Status Reason field. The Status field for the Case record type has three possible values: Active, Resolved, or Canceled. The Status Reason field stores a reason for a specific status value. For example, for a case with an Active status, a status reason could be In Progress, On Hold, Waiting for Details, or Researching.

Big organizations often have a large number of combinations for the Status and Status Reason fields. This can make it difficult for customer service reps to choose the correct next status reason. You can define status reason transitions to add another level of filtering for what the status reason value can be changed to for each status reason. Limiting these values to just allowed status reasons can help customer service representatives make the right choices.

1. Go to Settings > Customizations.
2. Click Customize the System.
3. In the solution explorer, in the left navigation pane, expand Entities, expand the Case entity, and then double-click Fields.
4. Go to the second page of fields, and then open the statuscode (Status Reason of Case) field.
5. In the Field: Status Reason dialog box, click Edit Status Reason Transitions at the top of the dialog box.
6. In the **Status Reason Transitions** dialog box, under **New Status Reasons**, click one of the **Enter Value** buttons corresponding with one of the existing status reasons.

7. In the **Select Status Reason** dialog box, in the **Available Values** list, select the values you want to add, and then click the chevron button to add to the **Selected Values** list. Click **OK** when you’re done with that status reason.

8. Click another **Enter Value** button to modify other status reasons. When you’re done, click **OK**.

**Note**

Each status reason option for an active status must allow at least one path to an inactive status. Otherwise, you could create a condition where it would not be possible to resolve or cancel a case.

9. In the **Status Reason Transitions** dialog box, select the **Enable Status Reason Transitions** check box to apply the defined status reason transitions to case records. The list of available status reasons will be filtered for each case record based on the defined transitions.
Create rules to automatically route cases

Use routing rules in Microsoft Dynamics 365 to automatically route cases to the right people at the right time without any manual intervention. You can also use routing rules to route cases that are escalated to specific queues.

Note

This feature was introduced in CRM Online Spring '14 update and in CRM 2013 Service Pack 1 (on-premises).

Create a routing rule set

Make sure that you have the Customer Service Manager, System Administrator, or System Customizer security role or equivalent permissions.

When you create and activate a routing rule set, internally a corresponding workflow is also created. Whatever action you do on the routing rule set, like creating or assigning the rule, you must have privileges to perform the same action on workflows. For the rule to work, you must have sufficient privileges to run a workflow. The routine rule set is applied in context of the privileges that the owner of the routing rule set has.

1. Go to Settings > Service Management.
2. Click Routing Rule Sets.
3. To create a new routing rule set, click New.
   -OR-
   To edit a routing rule set that you already have, in the list of records, click the rule that’s in the Draft state, and then on the command bar, click Edit.
4. Fill in your information. Use the handy tooltips as a guide.
5. After you enter information in all the required fields, click Save.

In the Rule Items section, click the Add Rule Item button + to specify conditions for routing cases to a queue.

You can add multiple conditions here and arrange them in the desired order. The rule items are run in the same order. As soon as an applicable rule item (based on the If Conditions) is applied on the case, the other rule items are not run on the case.

a. In the Rule Item form, type a descriptive name for the rule item.

b. Under Rule Criteria in the If Conditions section, specify the conditions for which the case will be routed.
   For example, to route all cases that have the IsEscalated field set to Yes to the Tier 2 support queue, specify the conditions as shown here:
c. Under **Then Conditions**, specify the queue to which the cases will be routed or the user or team to which the cases will be assigned if the conditions in the **If Conditions** section are met.

⚠️ **Tip**

To group conditions in the criteria, use the **Group And** or **Group Or** options.

6. Click **Save and Close**.

7. In the Routing Rule Set record, click **Activate** so that the rule set is applied to the cases matching the conditions in the rule.

✅ **Note**

- Only one routing rule set can be active at any point of time. If you try to activate another rule when one rule is already active, it will deactivate the currently active rule. You can activate or deactivate only the rules that you own.

- You can't edit an active routing rule set. Therefore, if you're importing a solution that includes an active routing rule set into an organization where the rule already exists with the same ID, the solution import will fail.

### Apply a routing rule set

An active routing rule set automatically applies to all automatically-created cases. To manually apply the rule to existing or manually-created cases, in the list of cases, select the cases that you want to route using this rule, and on the command bar, click **Apply Routing Rule**.

✅ **Note**

If you're importing bulk records, and you don't want the routing rules to apply to the cases that you're importing, add a column “Route Case” to your spreadsheet, and add the value “No” for all the cases that you don’t want to route.
Set up rules to automatically create or update records in Dynamics 365

Overview

Every organization has multiple applications to capture customer interactions. The ability to channel external data into Microsoft Dynamics 365 records can significantly improve the efficiency of your sales, marketing, and service teams, and increase the quality of your data. You can now direct this data from various applications and external sources into Microsoft Dynamics 365 with the help of record creation and update rules.

By using record creation and update rules in Microsoft Dynamics 365, you can automatically create or update system or custom records from incoming Dynamics 365 activities, such as emails, social activities, or custom activities, without writing any code. Not just that, you can set up the rule to convert the incoming activity into multiple Dynamics 365 records. For example, you can create a case and a lead from a single social activity.

A record creation and update rule consists of rule items that define the conditions for creating or updating records, and also defines what actions or steps to take on the newly-created records. The rule also contains channel properties that are used to define conditions for rules, and also for setting properties of the record you're creating or updating.

To enable the rule to update records, you must add an Update step to the rule. Only the entity that you select in the Update step is updated based on the properties you set.

Important

This feature was introduced in CRM Online 2015 Update 1 and CRM 2016 (on-premises).

Activities and entities supported by record creation and update rules

By default, Dynamics 365 supports creating records from the following activities, also called source types in the context of record creation and update rules:

- Email
- Social activity
- Task
- Phone call
- Appointment
- Service activity
- Custom activity

These activities can be converted to any default (system) entity records or custom entity records. For example, you could create a lead, opportunity (system record), or incident (custom record) from an incoming email.
Capture data from external sources
You can also capture additional valuable customer information provided by an external application in the form of JSON (a collection of name-value pairs), and use it to enhance the quality of the target records and set various conditions in the record creation and update rules.
Every default (out-of-the-box) activity or custom activity has an Additional Parameters attribute. This attribute stores the JSON payload received from an external application.
To capture this information in Dynamics 365, you can define channel properties and associate them with a particular rule or share them across multiple rules of the same source type. For example, along with a social post, you can capture important information about the post, such as sentiment value. Sentiment value is the property of social activity, so you can use this property in any other record creation and update rule of type Social Activity.
Here’s the correct format in which Dynamics 365 should receive the JSON payload (data received as a name-value pair in JSON format) from the external application:
{"PropertyName1":"Propertyvalue1"; “PropertyName2”:“Propertyvalue2”}

Note
Any configuration done in the channel properties is only valid if those name-value pairs exist in the JSON payload. Also, you must only use parameters received from the external application in the rule item conditions and as record properties.

Activate or deactivate a rule
For any record creation and update rule to apply to a matching incoming activity, after you add the rule items, you must activate the rule.
When a record creation and update rule is activated, a corresponding workflow is created automatically. You can use channel properties to define a workflow’s conditions and operators in mapping the target entity attribute values. For complex scenarios, you may configure child workflows.
More information: TechNet: Configure workflow steps

How do record creation and update rules work with queues?
In a record creation and update rule, when you specify a queue for a source type, any incoming activity from that source is added as a queue item for that specified queue. That is, if a rule for a particular source activity and queue combination is active, the rule processes the incoming activity on that queue to create or update records.
For an email source type, specifying a queue is mandatory. For all other source types including custom activities, it is optional.

Rules in solutions
The record creation and update rules can be packaged as a part of a Dynamics 365 solution. Customizers and developers distribute solutions so organizations can use Microsoft Dynamics 365 to install and uninstall the business functionality defined by the solution.
Keep the following things in mind about using rules in solutions:
• Any rule that you created in Microsoft Dynamics CRM Online 2015 Update 1 or later can't be exported to an earlier release.
• Any rules upgraded to and edited in Microsoft Dynamics CRM Online 2015 Update 1 or later can't be exported back to an earlier release.

Prerequisites

• This feature was introduced in CRM Online 2015 Update 1 and CRM 2016 (on-premises).
• Before you can use automatic record creation rules, be sure your external application/social engagement system is already integrated with your Dynamics 365 instance.
   If your Dynamics 365 instance meets the prerequisites, all you need to do is set up rules in Dynamics 365 that will automatically create or update a support case, lead, opportunity, appointment, task, and more from incoming activities.

Set up a rule to create and update records automatically
Make sure that you have the customer service, sales manager, or marketing manager role or equivalent permissions.

1. Go to Settings > Service Management or Business Management.
2. Click Automatic Record Creation and Update Rules.
3. To create a record creation and update rule, click New.
   - OR -
   To edit an existing rule, in the list of rules, open the rule you want to edit.
4. Type or modify information in the fields.
   Hover over the field labels to see what to enter.
   • Name. Type the name of the rule.
   • Source Type. From the drop-down list, select the activity that's the source of the record.
   • Queue. Select the queue the rule applies to. Incoming activity arrives in the queue, and then the valid rule and rule item applies for creation or update of records.
      Here are a few things to consider:
      • For all activities and custom activities, except email, specifying a queue is optional. For all such activities you can have only one rule with an associated queue and one rule without an associated queue active at any given time. For example, for a Social Activity source type, you can have two active rules, one with a queue specified, and one without a queue.
      • If you selected Email as the source type for this rule, you can't activate the rule unless you select a queue.

✓ Note
You can associate only one rule per source type to a specific queue. If you're creating a rule to convert an email to a case, make sure you specify an email address for this queue. Otherwise, automatic record creation for email won't work. More information: Create or edit a queue
5. Click **Save**.

6. Under **Channel Properties**, in the **Additional Properties** box, click a channel property group.

**Note**

When you select a property group for a record creation and update rule, you can use the channel property group’s property items in the rule item conditions or while setting properties for the target record. After you activate a rule, you can’t remove or change the selected property group. You can select another property group only after you remove the referenced property items of the previous property group from the rule items. When you try to select a new property group without removing the property references of the previous property group, you’ll see an error.

To learn more about creating channel property groups and adding properties to them, see the **Set up channel properties** section in this topic.

If the source type for the rule is set to **Email**, specify the conditions for converting the email to the target record.

**Specify the following details**

a. **Create records for email from unknown senders.** If you select this check box, all email messages from unknown senders (a sender whose email address isn't present in any Dynamics 365 records) are converted to new records (based on the conditions you define). A contact record is also created for this unknown sender.

**Note**

Dynamics 365 determines what record to create based on the entity you select in the **Create Record** step under **Actions**.

If you don’t select this check box, records are created only for email messages that have a Dynamics 365 contact or account as the senders.

This option, in conjunction with the **Automatically create records in Microsoft Dynamics 365** option in the rule owner’s Personal Options, determines whether a case and contact record is created.

b. **Create case if a valid entitlement exists for the customer.** If you select this check box, Dynamics 365 creates a record only if an active entitlement exists for the customer.

If the sender of the email is a contact with a parent account, Dynamics 365 creates a record if the contact’s parent account has a valid entitlement, and the contact is listed in the **Contacts** section of the entitlement or if the **Contacts** section is empty (which means the entitlement is applicable to all contacts for the customer).

c. **Create cases for activities associated with a resolved case.** If you select this check box, Dynamics 365 creates a case if the email is related to a resolved case. If the email is related to an active case, a new case won't be created.

d. **Create case when the case associated with the activity is resolved since.** If you select the **Create cases for activities associated with a resolved case** check box, select the duration here. Dynamics 365 creates a case only if the case is resolved earlier than the duration you specify. If the incoming email is related to a case resolved later than the specified duration,
Dynamics 365 only associates the incoming email with the existing resolved case; a new case won't be created.

e. **Send automatic email response to customer on record creation.** Select this check box if you want to automatically send email responses to the sender of the email after a target record for the email is created.

f. **Select email template to respond to customer.** If you select the **Send automatic email response to customer on record creation** check box, select an email template (global email template or email template of any entity type). If you don't select a template, an automatic response won't be sent.

If the source type for the rule is set to Social Activity, specify the conditions for converting the social activity to the target record.

**Specify the following details**

a. **Create records for blocked social profile.** If you select this check box, Dynamics 365 creates or updates a target record for the social posts (social activities) from social profiles that are blocked by you.

   📌 Note
   
   Social posts appear in Dynamics 365 as social activities.

b. **Create records for direct messages only.** If you select this check box, Dynamics 365 creates the target record only when the social posts are sent as direct or private messages. If you clear the check box, records are created for all social posts including public messages (timeline).

   📌 Note
   
   Dynamics 365 determines what record to create based on the entity you select in the **Create Record** step under **Actions**.

In the **Specify Record Creation and Update Details** section, click '+' to define the conditions for creating or updating a record and specify the properties of the record.

a. In the **Name** box, enter a meaningful name for the rule item.

b. In the **Conditions** section, select the record, channel properties, fields, and relational query operators to specify when a target record should be created or updated.

   For example, to create a record from a social post (social activity) with a sentiment value of less than 3, an influence score greater than 60, and hashtags containing SilverCreditCard, you can add the following conditions:
You can also use channel properties in your conditions.

Here's the rule item after you add all the conditions:
Add steps to create or update records for the incoming activity that matches the conditions you defined earlier.

i. Under **Actions**, click **Add Step > Create record**.

ii. In the **Create** box, select the record type for the record you want to create from the incoming activity. For example, if you want to create a case from the social activity, select **Case**.

**Note**

If the incoming activity has a regarding object set, and if the regarding object entity and the entity selected in the **Create Record** step aren’t the same, no workflow is applied and the actions defined in the rule are not executed.

iii. Click **Set Properties**.

The entity form is displayed. You can map the target entity fields to the social activity record data, including channel properties. Some of the mappings are available out of the box: Case title, Customer, and Origin (highlighted in yellow). The out-of-the-box mappings can be changed and new mappings can be added using the **Form Assistant** control.
The new record that is created will be automatically set as the regarding record of the incoming activity record. There is only one regarding object to the social activity, so, only one Create record action is possible in the Actions section.

iv. To add more actions, under Specify Other Actions, click Add Step > <Action>. The available actions are: Create Record, Update Record, Send Email, or Start Child Workflow. Learn more about each of these actions in TechNet: Configure workflow steps.

c. Click Save and Close.

Note

- Data types "Option Set" and "Two Option" are not supported in string type conditions.
- The property items for each of the supported data types need to have a default value. This requirement is important in scenarios where the configured property line items have a blank incoming web request. In such cases, the property line item will take the default value when referred to in a workflow.

7. Turn on the rule so that Dynamics 365 can start creating or updating records for incoming activities based on the defined conditions. More information: Activate a record creation and update rule.

Tip

Developers can also apply rules retroactively to the incoming Dynamics 365 records that might have been skipped while a rule was edited. More information: ApplyRecordCreationAndUpdateRuleRequest Class
Set up channel properties
Every default or custom activity has an Additional Parameters attribute. This attribute stores the JSON payload received from an external application.
You can find these parameters in the Additional Parameters field of any incoming activity.
To capture this information in Dynamics 365 and associate it with the record creation or update rule, you can define channel properties in a channel property group and associate them with a rule or share them across multiple rules. For example, along with a social post, you can capture important information about the post, such as rating or influencer score. Rating and influencer score are the properties of social channel.

Create channel property groups and add channel properties
1. After you save the record creation and update rule form, under Channel Properties section, in the Additional Properties box, click the lookup button, and then click New.

A channel property group form opens.

Important
A property group record contains multiple property items.
To fix this issue, first delete the properties from the conditions and steps that use the record, and then save or activate the rule.

2. Enter a meaningful name for the property group, so you can easily identify it while adding it to any record creation or update rule.
3. The Source Type field will be automatically set to the source type of the record creation and update rule.
4. Click Save.
5. In the Channel Properties section, click + to add in the group-specific channel properties.
6. In the Channel Property form, enter the following:
   a. Name. Type the property name as it appears in the activity’s payload.

Note
The name can contain only alphanumeric and underscore characters and shouldn't be longer than 300 characters.
To see properties received for an activity, go to Sales or Service or Marketing > Activities, and open the activity, and see the Additional Parameters field.

**Note**

This field isn’t available on the activity form by default. A system customizer can add the field to the activity forms. The field will have the JSON payload only when the external application sends it for the activity.

```
Additional Parameter: {
  "targetEntityName": "socialactivity",
  "socialHandle": "JuliaRice",
  "profileName": "JuliaRice",
  "profilelink": "http://twitter.com/JuliaRice",
  "community": "2",
  "fullName": "JuliaRice",
  "influencescore": "70",
  "favouritcount": "10",
  "retweetcount": "3",
  "retweeted": "true",
  "source": "<a href="http://twitter.com" rel="noreferrer" target="_blank">Twitter Web Client</a>"
}
```

**Important**

- Create a channel property for each name from the name-value pair that you want to use in your record creation and update rule. For example, you could use `influenceScore` as a property name.
- The information in the JSON payload isn’t very easy to read. To make it more readable, you can use online JSON parser that will provide a better output.
- The property group doesn’t support adding nested values in a JSON payload as channel properties. The following sample shows the "FollowersCount" under the user node as a nested JSON key-value pair.
b. **Data Type**. Select a data type for the channel property. For example, if the property is influence score, use the data type as Whole Number because its value can't be in decimals. The selected data type will determine the relational query operators when you use the property to define conditions in the record creation and update rule items. Dynamics 365 supports creating properties only of the following data types: Floating Point Number, Single Line of Text, and Whole Number.

**Note**

- Option Set and Two option data types are supported in conditions of type string. You'll have to type out the option set value in the conditions.
- Dynamics 365 sets a default value for property items for each of the supported data types. This is for scenarios when a channel property is used in a workflow but the incoming payload has no value provided from the external channel; the workflow conditions in which the property is referred use a least the following default value: String: "", Whole Number: -2,147,483,648, Float: -1e+011.

c. **Application Source**. Type the name of the application that this property is related to, for example, Microsoft Social Engagement.

d. **Description**. Type details to further explain what the property is for.

7. When you're done, click **Save & Close**. You can see all the properties in the channel property group form.
Activate a record creation and update rule
For any record creation and update rule to apply to a matching incoming activity, after you add the rule items, you must activate the rule.

To activate a record creation and update rule
1. Go to Settings > Business Management or Service Management.
2. Click Automatic Record Creation and Update Rules.
3. Open the rule you want to activate, and on the command bar, click Activate.

Note
You can have two record creation and update rules active at a time for any source type, except email—one with queue and one without a queue. You can have only one record creation and update rule active for the source type Email, and this rule should have a queue specified.

After the rule is active, the only way to change the rule is to first deactivate it. Open the rule, and on the command bar, click Deactivate.

Manage automatic record creation and update from a queue form
You can create or manage an automatic record creation and update rule from a queue form, too. To do this, open the queue record, and on the command bar, click Email Activity Conversion Settings or Social Activity Conversion Settings.
More information: Create or edit a queue

Upgrade considerations
Here are a few things you should know if you're upgrading to Microsoft Dynamics CRM Online 2015 Update 1 or later from an earlier release, and have existing case creation rules for email and social activity.
<table>
<thead>
<tr>
<th>Existing rules prior to upgrade</th>
<th>What happens to the rules after upgrade?</th>
</tr>
</thead>
<tbody>
<tr>
<td>A rule that has rule items with conditions and properties defined</td>
<td>• The rule and rule items are upgraded and the properties and conditions in the existing rule items are preserved.</td>
</tr>
<tr>
<td></td>
<td>• A new rule item is created with blank conditions. A new Create Record step (with Case selected) is added with out-of-the-box property mapping. The rule items are applied in an order and the newly-created rule item is considered last in the order.</td>
</tr>
<tr>
<td>A rule that has a rule items with conditions, but no properties defined</td>
<td>• The rule and rule items are upgraded and the conditions in rule items are preserved.</td>
</tr>
<tr>
<td></td>
<td>• A new rule item is created with blank conditions. A new Create Record step (with Case selected) is added with out-of-the-box property mapping. The rule items are applied in an order and the newly-created rule item is considered last in the order.</td>
</tr>
<tr>
<td>A rule that has a rule items with no conditions or properties defined</td>
<td>• The rule and rule items are upgraded.</td>
</tr>
<tr>
<td></td>
<td>• A new rule item is created with blank conditions. A new Create Record step (with Case selected) is added with out-of-the-box property mapping. The rule items are applied in an order and the newly-created rule item is considered last in the order.</td>
</tr>
<tr>
<td>A rule that has a rule items with properties, but no conditions defined</td>
<td>• The rule and rule items are upgraded and the properties in the rule items are preserved.</td>
</tr>
<tr>
<td></td>
<td>• A new rule item is created with blank conditions. A new Create Record step (with Case selected) is added with out-of-the-box property mapping. The rule items are applied in an order and the newly-created rule item is considered last in the order.</td>
</tr>
<tr>
<td>A rule with no rule items</td>
<td>• The rule is upgraded.</td>
</tr>
<tr>
<td></td>
<td>• A new rule item is created with blank conditions. A new Create Record step (with Case selected) is added with out-of-the-box property mapping. The rule items are applied in an order and the newly-created rule item is considered last in the order.</td>
</tr>
<tr>
<td>Existing rules prior to upgrade</td>
<td>What happens to the rules after upgrade?</td>
</tr>
<tr>
<td>---------------------------------------------------------------------</td>
<td>--------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td></td>
<td>in an order and the newly-created rule item is considered last in the order.</td>
</tr>
<tr>
<td>An active case creation rule for social or email source types, with</td>
<td>All such rules will be upgraded in an active state.</td>
</tr>
<tr>
<td>a queue specified</td>
<td>All such rules will be upgraded and deactivated. This is because even in Microsoft Dynamics CRM Online</td>
</tr>
<tr>
<td>An active case creation rule for social or email source types,</td>
<td>Online Spring ’14, a case creation rule without a queue did not apply and create any record.</td>
</tr>
<tr>
<td>without a queue specified</td>
<td></td>
</tr>
</tbody>
</table>

**Automatically create a case from an email**

Reduce the need for manually creating cases from incoming emails and increase the efficiency of customer service agents by creating automatic case creation rules in Microsoft Dynamics 365. The conditions in these rules automatically convert emails to support cases.

**Note**

This feature was introduced in CRM Online Spring ’14 update and in CRM 2013 Service Pack 1 (on-premises).

**Create cases automatically using rules**

Make sure that you have the Customer Service Manager, System Administrator, or System Customizer security role or equivalent permissions.

When a case creation rule is activated, a corresponding workflow is created automatically. If you create or assign a rule, you must have permissions to perform the same action on workflows. The case creation rule is applied and a case is created in context to the permissions that the owner of the case creation rule has.

1. Go to **Settings > Service Management**.
2. Click **Automatic Case Creation Rules**.
3. To create a new case creation rule, click **New**.
   - OR-
   To edit an existing rule, in the list of rules, select a rule, and then on the command bar, click **Edit**.
4. Type or modify information in the fields.
   Hover over the field labels to see what to enter.
   * **Name**: Type the name of the queue the rule is defined for.
   * **Source Type**: Select **Email** to indicate that cases will be created automatically from email messages.
- **Queue.** Select the queue that the rule applies to. For example, if you want to convert email messages and then send them to the Support queue, select that queue here.

  ☑ **Note**
  
  You can associate only one rule per source type to a specific queue. If you're creating a rule to convert an email to a case, make sure you specify an email address for this queue. Otherwise, automatic case creation for email won't work. More information: [Create or edit a queue](#)

In the **Specify Conditions for Case Creation** section, select the conditions for creating the case automatically. You can add multiple conditions here and arrange them in the desired order. The conditions are considered in the same order. Only one item that has conditions matching the incoming email is applied.

**Specify conditions for email to case creation**

a. **Create cases for email from unknown senders.** If you select this check box, all email messages from unknown senders (a sender whose email address is not present in any Dynamics 365 records) are converted to cases. A contact record is also created for this unknown sender.

  ☑ **Note**
  
  If this option is not selected, cases are created only for email messages that have a Dynamics 365 contact or account as the senders. Email messages from sender that are present as other record types in Dynamics 365 won't be converted to cases.

This option, in conjunction with the **Automatically create records in Microsoft Dynamics 365** option in the rule owner’s Personal Options, determines whether a case and contact record is created.

This table shows if a contact and case record is created based on the values set for the **Automatically create records in Microsoft Dynamics 365** field in Personal Options and the **Create cases for email from unknown senders** check box in the automatic case creation rule:
<table>
<thead>
<tr>
<th>“Automatically create records in Microsoft Dynamics 365” option is set to:</th>
<th>If “Create case from unknown sender” option in this rule is set to:</th>
<th>Contact or case created?</th>
</tr>
</thead>
<tbody>
<tr>
<td>Create Lead</td>
<td>Selected</td>
<td>Both, contact and case, created</td>
</tr>
<tr>
<td>Create Lead</td>
<td>Not selected</td>
<td>None</td>
</tr>
<tr>
<td>Create Contact</td>
<td>Selected</td>
<td>Both, contact and case, created</td>
</tr>
<tr>
<td>Create Contact</td>
<td>Not selected</td>
<td>Only contact created</td>
</tr>
<tr>
<td>None</td>
<td>Selected</td>
<td>Both, contact and case, created</td>
</tr>
<tr>
<td>None</td>
<td>Not selected</td>
<td>None</td>
</tr>
</tbody>
</table>

b. Create case if a valid entitlement exists for the customer. If you select this check box, Microsoft Dynamics 365 creates a case only if an active entitlement exists for the customer.

If the sender of the email is a contact with a parent account, Microsoft Dynamics 365 creates a case if the contact's parent account has a valid entitlement, and the contact is listed in the Contacts section of the entitlement or if the Contacts section is empty (which means the entitlement is applicable to all contacts for the customer).

c. **Create cases for activities associated with a resolved case.** If you select this check box, Microsoft Dynamics 365 creates a case if the email is related to a resolved case. If the email is related to an active case, a new case won't be created.

d. **Create case when the case associated with the activity is resolved since.** If you select the Create cases for activities associated with a resolved case check box, select the duration here. Microsoft Dynamics 365 creates a case only if the case is resolved earlier than the duration you specify. If the incoming email is related to a case resolved later than the specified duration, Microsoft Dynamics 365 only associates the incoming email with the existing resolved case; a new case won't be created.

e. Under **Specify Autoresponse Settings**, select the Send automatic email response to customer on case creation check box if you want to automatically send email responses to the sender of the email after a case for the email is created.

   **Select email template to respond to customer.** If you select the Send automatic email response to customer on case creation check box, select an email template (global email template or email template of case entity type). If you don't select a template, an automatic response won't be sent.

5. Click **Save**.

   In the **Specify Case Details** section, define the conditions for creating a case and specify the case properties.

   By default, the Title field of the new case is set to the subject of the email and the Customer field is set to the sender of the email. If the sender of the email is a contact with a parent account, the Customer field is set to the parent account, and the Contact field is set to the sender of the email.
Specify case details

a. In the **Specify Case Details** section, click +, and define the conditions for creating a case and specify the case properties.

b. In the **Conditions** section, specify when the case should be created.
   Here’s how:

![Condition](image)

   c. In the **Case Properties** section, set the properties for the case. The following example shows how to set the priority of all the automatically created cases to **High**:

   ![Case Properties](image)

   Once a case is created, the incoming email is removed from the queue.

   ✔ **Note**
   If there’s no routing rule to route the newly created case to another user or queue, the user who’s the owner of the case creation rule will be set as the owner of the case, too.

Activate or deactivate a case creation rule

Cases are created automatically only when the case creation rule is active. To activate a rule, open it, and on the command bar, click **Activate**.

Once the rule is active, you can’t change it. To change a rule, first open the rule and on the command bar, and click **Deactivate**. You can then edit the rule.

Manage automatic case creation from a queue form

You can create or manage an automatic case creation rule from a queue form, too. To do this, open the queue record, and on the command bar, click **Email to Case Settings**.

Set work hours for a resource (Customer Service)
Create or edit a service

To make scheduling services quick and easy, it’s helpful to predefine the specifics of the services you’d provide to customers. By using the service records in Microsoft Dynamics 365, you can define:

- How long a service activity would last
- What resources are available for the service activity, like users, facilities, or equipment

A service requires at least one selection rule and one or more resources, resource groups, or teams before the service can be scheduled with a service activity.

1. Navigate to the Business Management area.
2. Go to **Settings > Business Management**.
3. Click **Services**.
4. To create a new service, click **New**.
   -OR-
   To edit a service, open a service from the list.
5. Type or modify information in the text boxes.
   a. Under **General**, enter a name and description to reflect the specifics of the service and describe what the service is. Also, specify the initial status of the service activity when it is created. If your organization prefers to approve all service activities before committing them to the schedule, you can select **Requested** or **Tentative**.
   b. Under **Scheduling**, in **Default Duration**, select how long the service lasts. This can be changed when the service activity is created. The maximum duration of an appointment or service activity is 10 days.
   c. In **Start Activities Every**, select how often service activities can start. This allows the start times of service activities to be staggered.
   d. In **Beginning At**, select the time when the service activities must begin.
6. In the **Required Resources** area, define a selection rule:
   a. Choose a selection rule in the right-hand pane.
      Selection rules appear in the tree beside the **Selection Rule** button 🌳
   b. Choose one of the items under **Common Tasks** to define the selection rule by indicating how many resources are required and in what combination.
      **Add a Selection Rule**
      You can add complexity to a rule by adding a subrule to it.
      **Add Resources**
      Add users, facilities, equipment, or teams as resources to a selection rule.
      **Add Resource Groups**
      Resource groups are users, facilities, or equipment that can be scheduled interchangeably.

⚠️ Warning
You can save a service without defining a selection rule, but you won’t be able to schedule that service.
More information: Create or edit a selection rule

7. When you're ready to save your data, click Save.

Activate or deactivate a service
You can make a service available on unavailable for scheduling by activating or deactivating it. To do this, in the list of service records, select a service, then click More Actions > Activate or More actions > Deactivate.

Add facilities and equipment for service scheduling
Facilities and equipment are resources you’d use to perform services for your customers. Facilities could be physical spaces like service bays or conference rooms and equipment could be tools or other assets. Add these resources to Microsoft Dynamics 365 to ensure optimal services to your customers.

Add a facility or equipment
1. Go to Settings > Service Management.
   -OR-
   Go to Settings > Business Management.
2. Choose Facilities/Equipment.
3. On the command bar, choose New.
4. Fill in the information as required.
   • Name. Enter the name of the facility or equipment you want to add for service scheduling.
   • Business Unit. Dynamics 365 enters the business unit automatically. To choose a different business unit, choose the Lookup button and then select from the list.
   • Site. Select the location where the facility or equipment is located.

Tip
Make sure the site and the customer are in the same location. Resources for a given service activity should also be located at the same site.
• **Primary Email.** Enter the email address of the site manager or equipment manager. If there are any updates or cancellations related to the schedule, facilities, or equipment, notifications are sent to this email address.

• **Time Zone.** Select the appropriate time zone to determine availability for the facility or equipment. By default, this is set to the time zone you've selected in the General tab of the Set Personal Options dialog box. **Description.** Add details about the facility or equipment, such as the numbers, size, make, or model.

5. When you're done, choose **Save** or **Save and Close**.

### Create or edit a selection rule

Before you can add a resource to a service, you must define a selection rule to determine how resources are selected for service activities.

You can create a simple rule that selects resources from a list, and nest selection rules and sub-rules to create compound and complex rules. A compound rule selects a combination of resources, and a complex tree of selection rules selects from groups of equivalent resources.

You can also add resources to existing selection rules.

### Create a simple selection rule

This procedure assumes that no selection rules have been created previously for this service.

1. Go to **Settings > Business Management**.
2. Click **Services**.
3. In the list of services, open the service to which you want to add a selection rule.
4. On the **Service** form, click **Required Resources**, and then double-click or double-tap the first selection rule in the right pane.

   Selection rules appear in the tree beside the **Selection Rule** button 📊.

5. In the **Edit a Selection Rule** dialog box, enter the following information:
   - **Quantity**
     Select the number of resources required for the service. If you select **All**, all the selected resources are included in the service activity.
   - **Description**
     Enter any additional information about the scheduling rule you want to include.
   - **Selection Site**
This option defines whether the resources must all be from the same site or if they can be from any site in the business unit. This option is available only in the top-level selection rule.

6. Click OK.

7. Under **Common Tasks**, you can add resources:

   - To add individual users, facilities, equipment or teams to the selection rule, click **Add Resources**.
     In the **Look Up Records** dialog box, select the records you want to add. You can add as many records as you want, and they can be a mix of individual users, facilities, equipment, and teams.
   - To add resource groups to the selection rule, click **Add Resource Groups**.
     In the **Look Up Records** dialog box, select the records you want to add. You can add as many records as you want.

   **Tip**
   If you select multiple users in the **Look Up Records** dialog box and click **OK**, the **Save the selection as a Resource Group** dialog box opens. If you want to create a resource group from the selected resources, click **Yes, save the selection as a resource group with the name**, enter a name in the box, and then click **OK**. The new resource group appears in the selection tree.

8. Click OK.

9. Click **Save** or **Save and Close**.

   **Tip**
   After you set up the selection rule, create a service activity for the service rule and check the search results to verify that the results are what you expect.

---

### Create or edit a resource group

Use resource groups to group users, facilities, and equipment as part of the selection rules for a service.

#### Create a resource group

1. Go to **Settings > Business Management**.
2. Click **Resource Groups**.
3. On the Actions toolbar, click **New**.
4. In the **Resource Groups** form, enter information in the following fields:
   - **Name**
     You must enter a name for the resource group. Microsoft Dynamics 365 does not check that the name is unique.
   - **Business Unit**
To locate and select a business unit, click the **Lookup** button.

- **Description**
  You can add a detailed description of this resource group, including the criteria that you used to determine which resources to add to the resource group.

5. Click **Save**.
   After you save the record, **Resources** appears under **Common**.
6. Click **Resources**, and then on the Actions toolbar, click **Add Resources**.
7. In the **Look Up** dialog box, select the users, facilities/equipment, teams, or other resource groups to add to this resource group.
   Adding other resource groups to a resource group is a good way to manage large numbers of resources. For example, you could add the resource groups of "senior technicians" and "junior technicians" to a resource group of "technicians."
8. Click **OK** to add the selected resources to the resource group.
9. Click **Save** or **Save and Close**.

**Edit a resource group**

1. Navigate to your area.
   Go to **Settings > Business Management**.

2. Click **Resource Groups**.
3. Open the resource group you want to change.
4. In the **Resource Groups** form, change the information.
5. Click **Save** or **Save and Close**.

**Note**

Resource groups are published automatically when you save and close the form. If the new resource group doesn’t appear in the list of available resource groups for a service, or if changes are not appearing, you can manually publish the change by clicking **Publish** on the **Resource Groups** page.

To remove a resource, select the resource you want to remove from the resource group. On the Actions toolbar, click **More Actions**, and then click **Remove Resources**.

Installing a solution or publishing customizations can interfere with normal system operation. We recommend that you schedule a solution import when it’s least disruptive to users.
Use sites to manage your service locations

Create sites to define the locations where you provide service to your customers. When you’re scheduling resources, you can define which resources will work on which site.

1. Go to Settings > Business Management.
2. Click Sites.
3. On the Actions toolbar, click New.
4. Fill in your information. Use the handy tooltips as a guide.
5. Click Save.
6. To add resources, under Common, click Resources, and then click Add Resources.
7. In the Look Up Records dialog box, in the Look For drop-down list, you can add facilities/equipment or users as resources.
8. From the list of records, double-click a resource, and click Add.
9. Click Save and Close.

Set work hours for a resource

You can set the hours a user works or set the operating hours for a facility or equipment. By default, users, facilities, and equipment are set up for a 7-days-a-week, 24-hour schedule.

You can edit existing work hours by following steps 1 and 2 to go to the Users or Facilities/Equipment area. Then, open the resource you want to edit. Editing a schedule does not affect existing service activities created for the resource.

Set work hours for a facility or equipment

Make sure that you have the System Administrator, System Customizer, Sales Manager, Vice President of Sales, Vice President of Marketing, or CEO-Business Manager security role or equivalent permissions.

1. Go to Settings > Business Management.
2. Click Facilities/Equipment.
3. In the list, open the resource record you want modify.
4. Click Work Hours.
5. On the Monthly View tab, double-click a date on the calendar that is the first day you want the new schedule to start, or any date that will be affected by the new schedule.
6. In the Edit Schedule dialog box, select one of the following, and then click OK.
   - This date only
This option changes only the date selected. Skip to step 10.

- **From <this date> onward**
  This option changes only the schedule going forward.

- **Entire recurring weekly schedule from start to end**
  This option changes this entire schedule from the start to end date.
  Selecting this option might change past days, which may affect reports regarding hours worked in the past.

7. In the **Weekly Schedule** dialog box, in the **Set the recurring weekly schedule** section, select one of the following:

- **Are the same each day**
  The new schedule is the same for every day of the week. After you select this option, select the days of the week that the resource is available.

- **Vary by day**
  The new schedule is different for one or more days of the week. After you select this option, select the days of the week that the resource is available.

- **None. Resource is not working**
  The new schedule includes time that the resource is not working.

In the **Weekly Schedule** dialog box, you can also do any of the following:

- If the schedule is for more than one day, select the days of the week that this schedule is effective.
- If the resource does not work during business closures, select the **Observe** option.
- Under **Date Range**, in the **Starting on** box, you can change the date the schedule starts. You cannot change the date the schedule ends. To end a schedule, you must define a new schedule on that date.

8. Choose the work hours link for the schedule you want to modify.
   If work hours have not been set previously, the link is displayed as "Set Work Hours."

9. In the **Set Work Hours and Service Restrictions** dialog box, complete the following fields, and then click **OK**:

- **Date**
  Select a date from which the work hours for services are to be considered.

- **Start**
  Select the time the work day starts.

- **End**
  Select the time the work day ends.
  To add a break in the work hours, such as a lunch break, click **Add Break**, and then select the start and end time of the break.

10. To define a time when a service will not be available, on the **Service Restrictions** tab, click **New**.
    In the **Edit a Service Restriction** dialog box, select the service, and select the start and end time between which the service will be unavailable, and then click **OK**.
11. Click **Save and Close** to close the **Weekly Schedule** dialog box.

**Note**
- You can set the work hours for a single day by double-clicking the day, and then in the **Edit Schedule** dialog box, select **This date only**, then click **OK**. Then, perform step 10 in the procedure.
- All of the options may not be available to you for selecting how much of the schedule you want to edit. The available options are based on the schedules that are already set up.

### Set work hours for a user

1. Go to **Settings > Security**.
2. Click **Users**.
3. Open the user record you want to set work hours for.
4. On the top, select the arrow next to the name of the user.
5. Click **Work Hours**.
6. From the **Set up** drop-down list, choose the schedule display as required.

**Note**
Monthly schedules are the default display; you can choose weekly and daily schedules.

7. Double-click a date on the calendar that is the first day for which you want to set work hours.
8. In the **Edit Schedule** dialog box, select one of the following and then click **OK**.
   - **This date only**
     This option changes only the selected day.
     Skip to step 12.
   - **From <this date> onward**
     This option changes only the schedule going forward.
   - **Entire recurring weekly schedule from start to end**
     This option changes this entire schedule from the start to end date.
     Selecting this option might change past days, which may affect reports regarding hours worked in the past.
9. In the **Weekly Schedule** dialog box, in the **Set the recurring weekly schedule** section, select one of the following:
   - **Are the same each day**
     The new schedule is the same for every day of the week. After you select this option, select the days of the week that the resource is available.
   - **Vary by day**
The new schedule is different for one or more days of the week. After you select this option, select the days of the week that the resource is available.

- **None. User is not working**
  The new schedule includes time that the resource is not working.

In the **Weekly Schedule** dialog box, you can also do any of the following:
- If the schedule is for more than one day, select the days of the week this schedule is effective.
- If the resource does not work during business closures, select the **Observe** option.
- Under **Date Range**, in the **Starting on** box, you can change the date the schedule starts. You cannot change the date the schedule ends. To end a schedule, you must define a new schedule on that date.

10. Choose the work hours link for the schedule you want to modify.
If work hours have not been set previously, the link is displayed as "Set Work Hours."

11. In the **Set Work Hours and Service Restrictions** dialog box, complete the following fields, and then click **OK**:
- **Date**
  Select a date from which the work hours for services are to be considered.
- **Start**
  Select the time the work day starts.
- **End**
  Select the time the work day ends.
  To add a break in the work hours, such as a lunch break, click **Add Break**, and then select the start and end time of the break.

12. To define a time when a service won't be available, on the **Service Restrictions** tab, click **New**. In the **Edit a Service Restriction** dialog box, select the service, and select the start and end time between which the service will be unavailable, and then click **OK**.

13. To close the **Weekly Schedule** dialog box, click **Save and Close**.

---

**View, block, or deactivate a social profile**

Track the high influencers and the customers for your business, and save them as contacts in Microsoft Dynamics 365 with their social profile information. You may want to get in touch with these resources later, for marketing or brand building purposes.

With the social care sample, you can create a social profile and a corresponding contact automatically, every time you create a case. You can also create social profiles for the authors of the posts who have large number of followers or likes. These social profiles can be viewed in the **Services** area. If a social profile exists for the author of the post, a new profile is not created.

Every social profile has a corresponding contact in Microsoft Dynamics 365. A contact can have several social profiles, but a social profile can’t have several contacts.
View a social profile
1. Go to Service > Social Profiles.

The list of social profiles that are created in Microsoft Dynamics 365 appears.

Note
Social profiles aren’t available in Microsoft Dynamics 365 for Outlook with Offline Access.

2. Double-click any social profile to see the complete details.

The social profile form shows the name, profile link of the contact, and the cases associated with this social profile. You can also view the influencer score if it is included as part of the social feed.

Block a social profile
To make sure you receive only actionable social posts and avoid case creation for any unnecessary information, based on the social posts, you can block certain social profiles in Microsoft Dynamics 365.
1. Open the social profile you want to block.
2. In the Blocked drop-down menu, select Yes.
3. Click the Save button.

Deactivate a social profile
If you no longer work with a social profile, you can deactivate the profile temporarily. To do this, from the list of social profiles, select a profile, and click Deactivate on the command bar.
You can reactivate the profile by selecting it and clicking Activate on the command bar.

Set when your business is closed
Prevent scheduling resources on holidays and other nonworking days by defining business closures in Microsoft Dynamics 365. You can set both the days and times that your organization will be closed.

1. Go to Settings > Service Management.
2. Click **Business Closure**.

3. To create a new business closure, on the command bar, click **New**.

   - OR -

   To edit an existing business closure record, open it from the list.

4. In the **Schedule a Business Closure** dialog box, type or modify information in the text boxes:
   a. In the **Name** box, type a name that describes the purpose of the closure.
      The first 12 characters of the name appear on each day of the closure on the calendar view of the affected resource's **Work Hours**.
   b. In the **Start Time** and **End Time** boxes, enter the start and end date for the closure.
   c. If you want to enter duration instead of an end time, select the length of the closure in the **Duration** box. Microsoft Dynamics 365 automatically calculates the end time for you.
   d. If the closure is an all-day event, select the **All Day Event** check box. Microsoft Dynamics 365 automatically enters the duration of 1 day.
      If you want to enter a specific time period, clear the **All Day Event** check box. You can then specify the hours during which your organization will be closed.

5. To save this business closure, click **OK**.

---

### Schedule time off

You can schedule a period of time in the middle of a schedule when a resource is not available to be scheduled for a service activity. For a user, this could be a sick day or vacation. For a facility or equipment, this could be an equipment failure.

More information on scheduling a resource for business closure or holiday: Set or change work hours for a user, facility, or equipment.

1. Go to **Settings > Business Management**.
2. Choose **Facilities/Equipment**.
3. In the list, open the resource you want to modify.
4. Under **Common**, click **Work Hours**.
5. On the **Monthly View** tab, select a date on the calendar.
6. On the Actions toolbar, click **Set Up > Time Off**, and then in the **Schedule Time Off** dialog box, enter the following details:
   - **Reason**. Type a short explanation for the resource’s absence.
   - **All Day Event**. Select this check box if the resource is unavailable for the entire day (midnight to midnight) for all of the days.
   - **Start Time** and **End Time**. If you have not selected the **All Day Event** check box, you can set specific start and end times. When the end date is reached, the previous schedule continues.
   - **Duration**. If you don’t want to calculate the end date, select the number of days the resource is unavailable.
- **Time Zone.** If the resource is in a different time zone, select the time zone. Microsoft Dynamics 365 automatically adjusts the times on the calendars.

7. Click **OK**.
   
   In the working hours calendar, affected days are marked with a red block. In the Service calendar the time appears as a white block and cannot be scheduled.

You can update your own working hours or time off, and add yourself to teams and resource groups. On the **Tools** menu, click **Options.** On the **General** tab, at the bottom of the page, click the **user information** link.

### Navigate the service calendar

In the Service calendar, you can do the following tasks and activities:

- View your organization's daily, weekly, and monthly schedule of appointments and service activities.
- View work schedules and service activity schedules for a variety of resources.
- Create new appointments and schedule service activities.
- Change the status of an existing service activity.
- Search for conflicts in the schedule.

You can't customize the Service calendar or change the default view with the application. However, you can ask your system administrator to change the colors of the time blocks.

1. Go to **Service > Service Calendar.**

2. A list of resources is displayed on the left side of the calendar in alphabetical order. To view the resources, appointments, and service activities for anyone in your organization, in the **Type** list, select **Resource,** and then in the **View** list select the resource view.

3. To find a specific resource, in the **Search** box, enter the first few letters of a name.

4. To view the details of any resource, appointment, or service activity, select the record in the list to the left of the calendar, and then at the bottom of the calendar, under the **Zoom** scale, click the **Expand** button ▲ to expand the preview pane. You can also double-click a record to open it.

5. The Calendar pane appears on the right side of the calendar. It can be collapsed or expanded. To change the date, click a date in the calendar. Use the arrows on either side of the month to change the month displayed.

6. To change the number of days that are displayed in the linear calendar, click any of the calendar options in the Calendar pane.

7. To change how much of the calendar is available to view, use the **Zoom** scale. Select specific date ranges to view in the **From** and **To** lists.
Legend of colors and statuses
Appointments and service activities appear in the linear calendar as labeled color blocks. Move your mouse over these blocks to see the status of the appointment or service activity.

Create a customer service schedule and define the work hours

To define when your service or support team is available for providing support to customers, create a customer service schedule in Microsoft Dynamics 365. A customer service schedule determines the business hours for each day in a week and also the weekly off. Microsoft Dynamics 365 uses these details for time tracking of service level agreements (SLAs).

For SLA time tracking, make sure you add a holiday schedule to the customer service schedule, and associate this customer service schedule to the SLA record.

Important
This feature was introduced in CRM Online Spring ‘14 update and in CRM 2013 Service Pack 1 (on-premises).

Create a customer service schedule

1. Go to Settings > Service Management.
2. Click Customer Service Schedule.
3. To create a new customer service schedule, click + New.
   -OR-
   To edit a schedule that you already have, in the list of records, select the schedule, and on the command bar, click Edit.
4. In the Create Customer Service Schedule dialog box, in the Name box, type a meaningful name for the schedule, like “APAC Customer Schedule”, and click Create.
5. In the Weekly Schedule dialog box, under Set the recurring weekly schedule section, follow these steps:
### Weekly Schedule

#### Set the recurring weekly schedule

<table>
<thead>
<tr>
<th>Work Hours</th>
<th>Set Work Hours</th>
</tr>
</thead>
<tbody>
<tr>
<td>Are the same each day</td>
<td>Vary by day</td>
</tr>
<tr>
<td>Vary by day</td>
<td>24 x 7 support</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Work Days</th>
<th>Sun</th>
<th>Mon</th>
<th>Tue</th>
<th>Wed</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
</tr>
<tr>
<td></td>
<td>✔</td>
<td>✔</td>
<td>✔</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Holiday Schedule</th>
<th>Observe</th>
<th>Do not observe</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

#### Select the time zone

<table>
<thead>
<tr>
<th>Time Zone</th>
<th>(GMT-08:00) Pacific Time (US &amp; Canada)</th>
</tr>
</thead>
</table>

---

a. For work hours, select one of these options:

- **Are the same each day.** The schedule is the same for every day of the week. After you select this option, to select the days of the week that the customer support is available, click **Set Work Hours.**
  - To set the work hours for the days, click **Set Work Hours.** For more information, see the Define work hours for the customer service schedule section in this topic.
- **Vary by day.** The new schedule is different for one or more days of the week. After you select this option, select the days of the week that the customer support is available, and also specify the work hours for each day.
- **24 x 7 support.** The customer support is available 24 hours a day, and all days a week.

b. For **Work Days,** select the check box for each day that the customer support resources will be available and working.

c. For **Holiday Schedule,** select **Observe** to specify when your service organization will be closed.
  - If you selected **Observe,** select a holiday schedule from the lookup box. More information: Set up a holiday schedule (Customer Service)

6. Under **Select the time zone,** in the **Time Zone** drop-down box, select the time zone in which your customer support resources will work.

7. Click **Save and Close.**

---

### Define the work hours for the schedule

In the **Set Work Hours** dialog box, complete the following fields, and then click **OK:***

- **Start**
  - Select the time the work day starts.
- **End**
Select the time the work day ends. To add a break in the work hours, like a lunch break, click Add Break, and then select the start and end time of the break.

**Set up a holiday schedule**

Avoid having your service level agreements (SLAs) affected when your service organization is closed by creating a holiday schedule and adding it to your service calendar. For example, if your service organization has an SLA to reply to email cases within two business days, you can create a holiday schedule and add it to your service calendar. Then, if a customer submits an email case on that holiday, your SLA is clear and is not affected by the holiday closure.

**Important**

This feature was introduced in CRM Online Spring ‘14 update and in CRM 2013 Service Pack 1 (on-premises).

1. Go to Settings > Service Management.
2. Click Holiday Schedule.
3. Click +New and in the Create Holiday Schedule dialog box, enter a name and description for the holiday, and then click Create.
4. In the list of holidays, click the holiday you created.
5. When the holiday is open, click New to add the holiday to your customer service calendar.
6. In the Add a Holiday dialog box, specify the name and select the time of the holiday, and then click OK.

**Configure the process flow for customer service**

The process flow bar organizes tasks under various stages, which are used to easily lead you through the process of case resolution. The process flow bar also highlights the stages and tasks that you’ve already completed. You can configure the bar to add or update the stages, steps, and fields to suit your business needs.

For more information about customizing business processes, see eBook: Customize a business process.
To change stages, steps, and fields in the customer service process

1. From the case form, click the More Commands button, and then click Edit Process.
2. To add a new stage, click + Insert stage under the stage where you want to add the new stage. You can add up to 30 stages, and each stage can contain up to 30 steps.
3. Name the stage anything you like, and then add steps. To move the stage to where you want it to appear in the process, click the up and down arrows at the bottom of the form.
4. To add a step within a stage, click + at the bottom of the Step Name column, name the step, and then move it to where you want it to appear in the list of steps using the up and down arrows at the bottom of the form. Then click the associated field in the Value column and select from the drop-down list.
5. Click Save.

Create and manage a case

Keep track of your customer requests and issues by creating support cases in Microsoft Dynamics 365. When a customer contacts support with a question or problem, you can quickly check if there is an existing case or open a new case and start tracking the issue. You can also escalate, reassign, or put a case back into the service queue if you don't have enough information or time to work on it.

Before you provide support, you can also check the customer’s entitlements. Entitlements are like contracts that tell you what kind of support a customer is eligible for. You can see if the support terms are based on number of hours or cases, support channel, or based on the product or service that the customer has purchased.

To help you select the right status of a case, your admin may have set things up so that you only see a limited set of statuses based on the current status of a case. For more information on the available list of case statuses, contact your administrator.
Create a case

1. Go to Service > Cases.
2. Click New Case.
3. Find the customer:
   a. Click the Customer lookup button. By default, this field shows both account and contact records. Or, type a few letters and press Enter to search for records that contain the letters. When you select an existing customer, the customer details will show the contact details, along with recent cases and activities for the customer.
   b. If a customer record doesn’t exist, click New in the inline lookup results to create a new record.
4. Click the Contact lookup button and select an existing contact for the case or click New in the inline lookup results to create a new contact record.
5. Before you create a new case, check if there is an existing case:
   a. From the Identify area of the process bar, click the Find Case lookup button and then select a case from the list of cases.
b. If a case doesn't exist, click **New** in the inline lookup results to create a new case record.

6. In the **Case title** field, type a subject or descriptive name to identify the case.
7. To track your conversation with the customer, add activities. More information: **Add a phone call, task, email, or appointment activity to a case or record**
8. To see what kind of support you should provide the customer, click the **Entitlements** lookup button and select an active entitlement.

⚠️ **Important**
This feature was introduced in CRM Online 2015 Update and CRM 2015 (on-premises).
Interested in getting this feature? [Find your Dynamics 365 administrator or support person](#)

**Note**
- If your manager has set default entitlements for a customer, a default entitlement is automatically associated with a case when:
  - A case is created
  - A case is updated and the customer, contact, or product field has changed
- When a case is created and an entitlement is applied to it (or when the case gets resolved), the entitlement terms from the associated entitlement are decremented. However, if you don't want the entitlement terms to be decremented for a case, from the command bar click **Do not decrement entitlement terms**.

9. Fill in the other details that apply to the case, and then click **Save**.

**Find a solution from similar cases**
You can look at resolved cases to see if they can help you resolve the open case you're working on. For example, if the subject of the case you're working on is “Service outage,” you could look for resolved cases with the same subject to get help with your current case.

1. Go to **Service > Cases**.
2. In the list of active cases, open the case you're looking for.
3. When the case is open, to find similar cases, click **Case Relationships** to expand the menu.
4. For **Similar Cases**, click (+) **Add Connection record**.
5. From the Find Similar Cases dialog box, use the search to find similar cases.
   - Select a different subject to see the cases with that subject. You can also search for cases by typing the keyword in the search box, and then click the **Search** button. When you use a search keyword, it searches on the title of the case and shows the matching results.
6. When you find a similar case, click the case to review the case activities, posts, and notes.
Typically, a phone call, task, or case resolution activity has the information about how the case was resolved.

7. Once you find the case that has the information you need, click the case, and then click Found a Solution.
   The case you select is added to the Similar Cases area for the case you’re working on.

Resolve a case
For information about how to resolve parent and child cases, see “Resolve a case with a parent and child relationship” section in Create and manage parent and child cases (Customer Service).

1. Go to Service > Cases.
2. In the list of active cases, open the one you want to resolve.
3. On the command bar, click Resolve case.

   ✪ Important
   Before you resolve a case, make sure that all the case activities are closed. Otherwise, you’ll get a message saying that you still have open activities associated with the case, which will be canceled if the case is resolved.

4. In the Resolve Case dialog box, in the Resolution Type list, select how the case was resolved.
5. In the Resolution box, type a short explanation of the resolution.
   The actual time spent on all activities for this case, as recorded in the Duration box in each activity, is filled out automatically in the Total Time box.
6. In the Billable Time list, select the amount of time spent on the case to be billed to the customer.
   If this case is linked to a contract or entitlement, the billable time will be subtracted from the allotted minutes for that contract.
7. Click Resolve.
   A case resolution activity is created and shown in the Activities area. The resolution activity contains information about a resolved case, including the resolution and total time spent on the case. You can reactivate a resolved case at any time.

Edit a case
1. Go to Service > Cases.
2. From the list of cases, open the case you want to edit.
3. When the case is open, make the necessary updates to the case.
4. When you’re done, click Save.
Cancel a case

All case activities must be closed before you can cancel a case.
1. Go to Service > Cases.
2. In the list of active cases, open the case that you want to cancel, and then on the command bar, click Cancel Case.
3. In the Confirm Cancellation dialog box, select the case status:
   - Canceled: This means the case is canceled and it will no longer be assigned to you.
   - Merged: This means the case is merged into another case. When the case is merged, the case activities will be moved to the case it was merged into.
4. Click Confirm.

Reassign a case

If you don't have enough information to resolve a case, or if you think another member in your team has expertise on the subject, you can assign the case to another user or team.
1. Go to Service > Cases.
2. Select the case that you want to reassign.
3. Do one of the following:
   a. If using the web app: On the command bar, click More Commands [more] and select Assign.
   b. If using Dynamics 365 for Outlook: In the Collaborate group, click Assign.
4. Click the Lookup button [search], and select who you want to assign the case to.
5. Click Assign.

Add a case to a queue

If you think another group in your team has the expertise on the subject, you can move the case to a queue so that someone else can pick it up.
1. Go to Service > Cases.
2. Select the case that you want to add to a queue.
3. Do one of the following:
   a. If using the web app: Click the More Commands icon [more], and select Add to Queue.
   b. If using Dynamics 365 for Outlook: In the Collaborate group, click Add to Queue.
4. Click the Lookup button [search], select the queue that you want to add the case to, and then click Add.
Save and route a case

When you create a new case, you can save it and route it with a single click using the Save & Route button.

1. Go to Service > Cases.
2. Open a case record.
3. On the command bar, click Save & Route.
4. In the Route Case dialog box, click Route.
   The case is routed based on the active routing rule set.

Important
- The Save & Route button is available only on active cases.
- The Apply Routing Rule button that was earlier available on the case form is now available in the list of records for applying the routing rule on multiple cases.

Add a phone call, task, email, or appointment activity to a case or record

The activity and notes area helps you keep track of all the interactions with your customers. Record all important conversations with the customer or the communication with your team members regarding a record in Microsoft Dynamics 365. Add a phone call, task, notes, email, or appointments right within the case, account, contact, lead, or opportunity records without navigating to a different area and opening another form.

All activities that you add from within a record appear in the Activities area. If the Regarding field of an activity is set, the activity appears in the activity wall of the regarding record. You can filter the list to show just the activities that are in progress or the ones that are overdue. Click or tap the inline Complete link to close the activity as Completed.
Add a phone call

1. Open the record you want to add the activity to.

2. If you do not see the Add Phone Call area open in the middle of the page, click Activities > Add Phone Call.

3. In the Description area, provide a summary of the conversation with the customer. You must fill in this area before you can save the phone call.
   The Call With field is automatically populated with the customer name you select in the account or contact field. You can select a different contact, account, lead, or user record if required.

4. By default, the direction is set to Outgoing. You can change it to Incoming by clicking or tapping the Phone Support button in the list of case records. To select multiple records, click Look Up More Records, and then in the Look Up Records dialog box, select the records.

5. Select the Left voice mail check box if you make an outgoing call to a customer and leave a voice mail for them. You can also select this check box if a customer leaves a voice mail message when they call you.

6. Click OK to save the activity.

Note

By default, every phone call activity that you add in context of a record is marked Completed when the record is saved at least once. However, if you add a phone call activity to an unsaved record, or if you create a new activity and then set the Regarding field of the activity to another entity record, the activity is set to an Open state. You can click the Complete link to close the activity as Completed. The Complete link is available only after you save the case record at least once.
Add a task
1. Open the record you want to add the activity to.
2. In the middle of the page, click Activities > Add Task.
3. Fill in your information. Use the handy tooltips as a guide.
4. The Owner field is set to the current user by default. If you want to reassign the task, click the lookup icon, and then select another user or team.
5. Click OK to save the task.

Add an email
To add an email activity to a record, you must first save the record you are adding the activity to.
1. Open the record you want to add the activity to.
2. In the middle of the page, click Activities > More Commands > Email.
3. Fill in your information. Use the handy tooltips as a guide.
4. To save the record, click Save.
5. To add an attachment to the email, under Attachments, on the right, click +.
6. To use a template for the email body, in the email editor, click Insert Template, and then select the template.
7. To attach an article to the email, in the email editor, click Insert Article, and then add the article.
8. Click Save.

Add an appointment
To add an appointment activity to a record, you must first save the record you are adding the activity to.
1. Open the record you want to add the activity to.
2. In the middle of the page, click Activities > More Commands > Appointment.
3. Fill in your information. Use the handy tooltips as a guide.
4. To save the record, click Save.

Add notes
You can also easily add notes in the activities area. And if you’re on the latest version of Microsoft Dynamics 365 (online), you have the benefits of using OneNote to take or review customer notes from within your Dynamics 365 records. This doesn’t replace the current Notes feature, but gives you another way to access notes stored in OneNote.
1. Open the record you want to add the activity to.
2. In the middle of the page, click **Notes** or **OneNote**. Then do one of the following:
   - In the **Notes** area, start typing your notes.
   - In the **OneNote** area, select a notebook to make entries.
The notebook is stored in the associated SharePoint folder for the record. If there is more than one associated folder, the notebook is created in the first folder.

Create an activity and associate it with a customer

You can also create an activity from the Activity area and then link it to a customer or support case.

1. Go to your work area.
2. Go to Activities.
3. On the command bar, select and add an activity. Fill in your information. Use the handy tooltips as a guide.
4. Use the **Regarding** field on the activity form to associate it with a customer or support case.

---

**Use articles in the knowledge base**

Make critical knowledge available to everyone by capturing it in articles in Microsoft Dynamics 365. Create a customized library for business information, product guides, data sheets, and other articles with timely and relevant information.

An administrator sets up a subject tree to categorize articles based on your organization's unique needs. New articles can be based on templates that define the structure for individual articles, such as the question and answer sections in a FAQ.

After your organization has some articles in Microsoft Dynamics 365, you can link them to a case or even send them to customers in email.

A typical knowledge management process consists of the following stages:

---

**Create and update articles**

Collaborate with colleagues while writing or editing your articles. Review suggestions, corrections, and additions in the comments on an article, and then update the article based on these comments. When you're done, send your article to a manager for approval. When approved, it is available in search results, to view, or to share with colleagues and customers after about 15 to 20 minutes.

1. Go to **Service > Articles**.
2. To create a new article: Click **+New**.
   - To edit an article, open the article from the list.
3. If you are creating a new article, in the **Select Template** dialog box, select a language and template you want to use to create the article, and then click **OK**.

   ✓ **Note**
   
   If you need other templates, you can ask your system administrator or customizer.

4. Type or modify information in the text boxes.
   - **Hover**tips provide hints about what to enter.
   - All articles are initially created in a Draft state. To publish the articles, a manager needs to approve these.
5. In the **Actions** group, click **Submit**.

---

**Edit, reject, or approve an article**

To make sure the articles that people in your organization use are up to date, someone with manager privileges needs to approve any new or revised articles. Similarly, managers can remove unneeded articles.
• To view or edit an unapproved article, on the nav bar, click Microsoft Dynamics 365 > Service > Articles, open the Unapproved Articles view, and then click the article. To add comments to the article, in the Actions group, click Add Comments.

• To reject an article, open the article, and in the Actions group, click Reject. Rejected articles are returned to the Unapproved Articles view for revision.

• To approve an article, in the list of unapproved articles, select the article, and then on the command bar, click APPROVE.

When you approve an article, it is automatically published and available for viewing in the knowledge base in approximately 15 minutes. After an article is published, if you want to edit it, you must first unpublish it.

Find an article
Microsoft Dynamics 365 provides several ways to look for articles that people in your organization have created. You can search by using keywords, titles, or the text from a published article. If you know the exact article number, you can quickly open the article you need. But if you aren’t sure what text to use before you begin looking, you can also browse through articles by subject.

1. Go to Service > Articles.
2. In the Search box, type the keyword, and then click the Search button.
3. To filter search results, click the Search Tool button, and then select one of the following:
   - Full-Text Search. Looks at all the published articles for the specified keyword.
   - Keyword Search. Compares the keyword you specified with alternate terminology assigned to an article to find articles. For example, an article about bicycles might use keywords like "bike" or "cycle."
   - Title Search. Looks at the title of all published articles for the keyword you specified.
   - Subject Search. Looks at the subject of all published articles for the keyword you specified.
   - Article Number Search. Looks for the number that is assigned to the article when it is published.
   - Subject: ‘None’. Looks for articles that have None selected as the subject.

Select Exact Text to search for the exact words you enter in the Search for box, or select Use Like Words to search for similar words. For example, if you enter "run," the search will include "running" and "runs."

Merge similar cases
Eliminate redundancies between similar cases in Microsoft Dynamics 365 by merging them into one case. When a customer opens multiple cases about the same issue (through different support channels), or when multiple customers from the same account call in about the same issue, you can merge those cases into one case so everything’s visible in one place.
For example, when a customer or multiple customers from the same account submit a case on the web and also call in about the same issue, you can merge the cases into one case instead of keeping track of multiple cases.

When a case is merged, the state of the case is changed to canceled, and the status is changed to merged. This is because it is merged into another case and all of the open case activities, emails, and attachments are now associated with the case it was merged into. By default you can merge up to 10 cases at a time.

A few things to remember when you merge cases with parent and child relationships:

- When you merge a case that has child cases, those child cases become child cases of the parent case they were merged into.
- You can only merge a child case into another child case if both of the child cases have the same parent case.

More information: [Create and manage parent and child cases](#)

**Important**

This feature was introduced in CRM Online Spring '14 update and in CRM 2013 Service Pack 1 (on-premises).

1. Go to Service > Cases.
2. In the list of active cases, select the cases you want to merge. You must select at least two active cases.
3. On the command bar, click Merge Cases.
4. In the Merge Cases dialog box, from the list of cases, select the case the other cases will be merged into, and then click Merge.
5. To see the merged case, open the case it was merged into, and you'll find the merged case listed under Case Relationships > Merged Cases.

### Create and manage parent and child cases

You can manage multiple cases more efficiently if you use parent and child cases in Microsoft Dynamics 365. When you need to track a case where work needs to be done by other departments or when you need to track the same issue for multiple customers, you can open a primary case called the parent case, and then create secondary cases called child cases.

For example, if you get a service request to install new electrical and gas connections, this requires work to be done separately by the gas and electric department. In this situation, you can open two child cases, one for the gas and the other for the electric department. The original case is marked as the parent case. Once the child cases are resolved, you can then close the parent case.

Similarly, you can create parent and child cases when multiple customers call in about the same issue, for example, a network outage. Instead of creating a new case for each customer, you can create a parent case to track the main network outage with the Network Operations team, and then create child cases when customers call in about the issue.
Note, a child case can't have a child case.

很重要的

This feature was introduced in CRM Online Spring ‘14 update and in CRM 2013 Service Pack 1 (on-premises).

Interested in getting this feature? More information: Find your Dynamics 365 administrator or support person

Create a new child case

When you need to create a child case for the case you're working on, you can quickly do this from the case form.

很重要的

A case can only have up to 100 child cases.

1. Go to Service > Cases.
2. When the case form is open, do one of the following:
   - On the command bar at the top, click Create Child Case.
   - Or, choose to expand Case Relationships, and next to Child Case, click (+) Add Case record.
3. Next, fill in the necessary case information for the child case, and then click Save.
4. To see the child case that was just created, from the parent case, click Case Relationships, and you’ll see the child case listed under Child Cases.

**Associate a parent case to a child case**
You can create a case and then associate it as child case.

☑️ Note
A child case can't have a child case.

1. Go to Service > Cases.

Then, do one of the following:

**From your active list of cases, do this:**
   a. Select the cases that you want to associate as parent and child case(s). You must select at least two cases.
   b. On the command bar at the top, click Associate Child Cases.
   c. In the Set Parent Child Relationship dialog box, from the list of cases, select the case that you want to make the parent case, and then click Set.

**From an open case, do this:**
   a. From the open case form, choose to expand Case Relationships, and next to Child Case, click (+) Add Case record.
   b. Click the Lookup button, and then find the case you want associate as the child case.

**Associate a child case to a parent case**
You can associate a parent case to a case from the case form.
1. Go to Service > Cases.
2. Open the case that you want to link a parent case to.
3. From the case form, click the Parent Case and use the search to find a case that you want to associate as the parent case for this case.

**Resolve a case with a parent and child relationship**
Depending on your settings, a case with a parent and child relationship can be closed in one of the following ways:
Important

Sometimes, resolving a case action might be blocked based on your current case status. This is because your admin may have set things up so that you only see a limited set of statuses to choose from based on the current status of a case. For more information about the available list of case statuses, contact your administrator.

- When all the child cases are resolved, you can then close the parent case.
- When you resolve the parent case, it will then resolve all the active associated child cases.
- A parent and child case can be closed independently of each other. This is the default setting.

1. Go to Service > Cases.
2. In the list of active cases, open the one you want to resolve.
3. On the command bar, click Resolve case.

Important

Before you resolve a parent case with active child cases, make sure that all the case activities are closed. Otherwise, you'll get a warning stating that you need to manually close the open activities or the system will automatically cancel the open activities when the case is resolved. Also, performance may be slow when you close a parent case with lots of active child case associated with it.

4. In the Resolve Case dialog box, in the Resolution Type list, select how the case was resolved.
5. In the Resolution box, type a short explanation of the resolution.
   The actual time spent on all activities for this case, as recorded in the Duration box in each activity, is filled out automatically in the Total Time.
6. In the Billable Time list, select the amount of time spent on the case to be billed to the customer.
   If this case is linked to a contract or entitlement, the billable time will be subtracted from the allotted minutes for that contract.
7. Click Resolve.
   A case resolution activity is created and shown in the Activities area. A case resolution activity contains information about a resolved case, including the resolution and total time spent on the case. You can reactivate a resolved case at any time.

Find what's assigned to you in a queue

Quickly see the items assigned to you or that are available to work on by using queues in Microsoft Dynamics 365. Think of them as to-do lists that help you organize your work.

Important

For Microsoft Dynamics 365 (online) organizations, some features like picking or releasing items are available if you’ve applied product updates for CRM Online Spring ‘14 or later, or if you’ve installed the CRM Online 2015 Update or later. For on-premises Dynamics 365 organizations, these features
are available if you’ve installed CRM 2013 Service Pack 1 (on-premises) or later, or if you’ve updated to CRM 2015 or later.

**Find the queue items**

Use the View list and Queue list to filter and find items in queues.

1. Go to **Service > Queues**.

Select a view and a filter to see the items that you want.

**Find all cases in selected queues**

a. To see all cases from the selected queue, in the **View** list, click **All Cases in Selected Queues**.

b. In the **Queue** list, choose one of the following options to filter cases based on queues:
   - <Individual Queues>
   - All Queues
   - All Public Queues.
   - Queues I’m a member of

**Find all items in queues**

a. To see all cases from the selected queue, in the **View** list, click **All Items in Selected Queues**.

b. In the **Queue** list, choose one of the following options to filter cases based on queues:
   - <Individual Queues>
   - All Queues
   - All Public Queues.
   - Queues I’m a member of

**Find cases that are available to work on**

a. To see only the cases that no one else is working on, in the **View** list, click **Cases Available to Work On**.

b. In the **Queue** list, choose one of the following options to filter items based on queues:
   - <Individual Queues>
   - All Queues
   - All Public Queues
• Queues I’m a member of

**Find cases that you’re working on**

a. To see only the cases that you’re currently working on, in the View list, click **Cases I am Working on**.

b. In the Queue list, choose one of the following options to filter the cases based on queues:
   - <Individual Queues>
   - All Queues
   - All Public Queues
   - Queues I’m a member of

**Find items available to work on**

a. To see only items (activities and cases) that no one else is working on, in the View list, click **Items available to work on**.

b. In the Queue list, choose one of the following options to filter items:
   - <Individual Queues>
   - All Queues
   - All Public Queues
   - Queues I’m a member of

**Find items that you’re working on**

a. To view only items that you’re currently working on, in the View list, click **Items I am working on**.

b. In the Queue list, choose one of the following options to filter items:
   - <Individual Queues>
   - All Queues
   - All Public Queues
   - Queues I’m a member of

**Pick an activity or case to work on**

1. In the View list, select one of the views that show the items or cases available to work on.

2. Select the case or item that you want to work on, and on the command bar, click **Pick**.

You also have an option to remove the item from the queue once you pick it up.

When you pick an activity or a case, it gets assigned to you. The **Worked By** field (in the list of queue items) is also set to you if you leave the activity or case in the queue.
Release an item or case that you’re working on so someone else can pick it up

1. In the **View** list, select one of the views that show the items or cases you’re working on.
2. Select the case or item that you want to release, and on the command bar click **Release**.

When you release an item, your name is removed from the **Worked By** field, and the item is no longer assigned to you; it’s assigned to the queue owner.

Route an activity or case to another queue or assign to a different user or team

1. Select the case that you want to move to another queue, and on the command bar click **Route**.
2. To move an activity or case to a different queue, click **Route**, and select a queue.

  ◊ **Important**

  If you’re using CRM 2013 SP1 or CRM Online Spring ’14, and you click **Look Up More Records**, you’ll only see business queues, which is the default view. Business queues only include user-created queues and leave out all user and team queues. You can't set a different view as the default view. To choose a different queue, in the **Look Up Records** dialog box, in the **Look in** list, click the **All Queues** view.

  -OR-

  To assign the activity or case to another user or team to work on, click **User/Team**, and select the user or team. When you assign the activity or case to someone else to work on, the **Worked By** field is set to that user or team. You also have the option to remove the item from the queue.

Remove an activity or case from a queue

1. In the **View** list, select one of the views that show the items you want to remove.
2. Select the activity or case, and on the command bar, click **Remove**.

Assign an activity to a user or queue

If you want another person in your organization to work on an activity, you can assign the activity to that person or move it to another queue.

Assign to another user or team

1. Go to **Activities**.
2. If using the Dynamics 365 web application: In the list of activities, select the activity you want, and on the command bar, click **More Commands***, and then click **Assign**.
   If using Dynamics 365 for Outlook: Expand **My Work**, and then click **Activities**.
   a. In the list of records, click the record you want.
   b. In the **Collaborate** group, click **Assign**.
3. In the **Assign to another user or team** field, click **Lookup**, and select the user or team you want to assign the activity to.
   If you don’t see the user or team you are looking for, click **Lookup**, and then click **Look Up More Records**. From the **Look for** drop-down list, select **User** or **Team**. In the **Search** box, type the name, click the search button, and then click the name to select it. Click **Add**.
4. Click **Assign**.

**Add to a queue**

1. Go to **Activities**.
2. If using the Dynamics 365 web application: In the list of activities, select the activity you want, and on the command bar, click **More Commands***, and then click **Add to Queue**.
   If using Dynamics 365 for Outlook:
   a. In the list of activities, select the activity you want, and on the command bar, click **More Commands***, and then click **Add to Queue**.
   b. In the **Collaborate** group, click **Add to Queue**.
3. In the **Queue** field, click **Lookup**, and select the queue you want to route the activity to, and then click **Add**.

**Basics of service and service scheduling**

Avoid disruptions in service by making sure that your resources are scheduled optimally and efficiently. Learn the basics of getting started with managing services and service scheduling in Microsoft Dynamics 365.

**Understand the service terminology**

- **Service**: A type of work, such as a maintenance activity, performed for a customer by one or more resources. Services are schedulable activities.
- **Resource**: Users, facilities or equipment, or teams that can be scheduled and have work schedules.
- **Resource groups**: Groups of resources that can be scheduled interchangeably.
- **Work hours**: The hours that a resource is available for scheduling.
- **Site**: The location of a resource. Use sites to make sure that the customer and the resource are in the same location.
• **Service activity**: A schedulable appointment to provide a service to a customer. A service activity uses one or more resources to perform a service at a specific time and place. An appointment is a schedulable activity that does not use services and does not require a resource with work hours.

• **Scheduling rule**: A set of criteria that specifies which personnel, equipment, facilities, or resource groups are required to perform a service, or how to select these resources, based on parameters like quantity and capacity.

### Select resources for service

When you add a resource to a service, create a selection rule to determine how resources will be selected for service activities.

You can create a simple rule that selects resources from a list, or a compound rule that selects a combination of resources, or a complex tree of selection rules that selects from groups of equivalent resources.

More information: [Create a simple selection rule (Customer Service)](#)

### Capacity vs. effort—understand the difference

You can set up services and resources in Microsoft Dynamics 365 to take into account different-sized facilities or the experience levels of your users when a service is scheduled. This is known as capacity scheduling. Capacity is a relative unit that you define. For example, you could define capacity in a bicycle repair shop as the number of bikes the shop has room to accommodate at the same time. If a repair bay has room for four bike-repair stations, the repair bay can accept four bikes for repair or inspection at the same time.

Capacity can also measure skill level. For example, a junior bike technician has the ability to perform one bike inspection per hour, and a senior technician has the ability to perform four bike inspections per hour. If two bikes must be inspected in one hour, it takes either two junior technicians, or one senior technician who can perform the inspections in half the time.

When you add effort required into the selection rule, every time a user searches for an available service activity time, the selection rules inspect the resources for capacity available. If the resource is scheduled, then that resource's capacity is reduced by the effort required for the service. This is repeated every time that a service is scheduled requiring that resource, until the capacity is exhausted.

Capacity is defined in the resource's working hours. Effort required is defined in the service. You can think of capacity as "how much money you have" and effort required as "how much something costs."

For example, the repair bay has a capacity of four. A bike repair requires an effort of one and a tandem bike repair requires an effort of two. The first time the repair bay is selected, its capacity is reduced to three for that time. The next service activity scheduled is for a tandem bike. This reduces the repair bay's capacity by two. The repair bay has the capacity of one left, which means it could accept another bike repair, but not a tandem bike repair.

### Add resources to existing services

You can add as many resources as you want, and they can be a mix of individual users, facilities, equipment, and teams. More information: [Create or edit a service (Customer Service)](#)
Use resource groups
Use resource groups to group users, facilities, and equipment as part of the selection rules for a service. You can add resources to a resource group from the service record. More information: Create or edit a resource group (Customer Service)

Test your service
Before you start using a service, test it. Create a service activity with no criteria other than the service. You can use the results to confirm that the service is selecting correctly. The message bar will also display any problems with the search.
1. Click Microsoft Dynamics 365 > Service > Service Calendar.
2. Click Service Activity. This bypasses the scheduling form.
3. Select the service to test.
4. Click Find Available Times.

Set the capacity required for a service or resource
Define a limit to the number of activities a resource can perform in a stipulated time by setting the capacity of the resource and services in Microsoft Dynamics 365.
You must set both the capacity of the service and of the resources required for the service.
When you set capacity of a resource and service, the service calendar doesn’t allow booking the resources once they reach their capacity.

Set the capacity of a service
Before you start, make sure you have the Schedule Manager role assigned or have the required permissions for doing the scheduling tasks.
1. Go to Settings > Business Management.
2. Click Services.
3. In the list of services, open the service you want to set the capacity for.
4. Under Required Resources, in the column on the right, double-click or tap the selection rule you want to modify.
5. In the Edit a Selection Rule dialog box, expand the Scheduling Details area.
6. In Select Criteria, to make sure everyone has the same workload, select Least Busy. Or, to make sure each member works at full capacity before assigning work to anyone else, select Most Busy.
7. In Capacity Required, specify the capacity required by a resource to perform this service.
   For example, a workshop has four work compartments. The capacity of the workshop is 4, that is, the workshop can have four different services scheduled for the same time. You can then add
different workers, where the more skilled workers complete two tasks at once, so their capacity can be set to 2. They can have two jobs scheduled for the same time.

8. Click OK.

Set the capacity of a resource

1. Go to Settings > Business Management.
2. Click Facilities/Equipment.
3. In the list of records, open the record you want to set the capacity for.
4. In the user record, on the nav bar, click the chevron button next to the record name, and then Work Hours.
   -OR-
   In the Facilities/Equipment record, under Common, click Work Hours.
5. On the Monthly View tab, double-click the date on the calendar that is the first day you want the new schedule to start, or any date that will be affected by this edit.
6. In the Edit Schedule dialog box, select one of the following and then click OK:
   a. This date only. This option changes only the date selected. If you select this option, skip to step 8.
   b. From <this date> onward. This option changes only the schedule going forward.
   c. Entire recurring weekly schedule from start to end. This option changes this entire schedule from the start to end date. Selecting this option might change past days, which might affect reports regarding hours worked in the past.
7. In the Weekly Schedule dialog box, click the work hours link for the schedule you want to edit.
   If working hours have not been set previously, the link is displayed as “Set Working Hours.” You must set up a schedule for a user, facility, or equipment before you can continue. More information: Set work hours for a resource
8. In the Set Work Hours and Service Restrictions dialog box, click Show Capacity, and then in the Capacity column, enter the capacity.
9. Click OK.
10. Click Save & Close.

Restrict a resource from performing a service

You can restrict a resource from performing a service and define the service capacity for the resource. You can also restrict when a resource is available to be scheduled for a specific service. The resource is still available for scheduling service activities for other services.
Make sure that you have the System Administrator, System Customizer, Sales Manager, Vice President of Sales, Vice President of Marketing, or CEO-Business Manager security role or equivalent permissions.

1. Go to Settings > Administration.
2. Click Users.
3. In the list, open the resource record you want to modify. The resource name appears in the nav bar. Click the arrow beside the resource name and select Work hours.
4. Under Common, click Work Hours.
5. On the Monthly View tab, double-click a date on the calendar that is either the first day you want to restrict the resource from performing the service or a date in a recurring schedule.
6. In the Edit Weekly Schedule dialog box, select one of the following options, and then click OK.
   - **This date only**
     This option changes only the date selected.
     If you select this option, skip to step 8.
   - **From <this date> onward**
     This option only changes the schedule going forward.
   - **Entire recurring weekly schedule from start to end**
     This option changes the entire schedule from the start to end date.
     Selecting this option might change past days, which may affect reports regarding hours worked in the past.
7. In the Weekly Schedule dialog box, click the work hours link for the schedule you want to modify.
8. In the Work Day dialog box, click the Service Restrictions tab.
10. In the Service Restrictions dialog box, find and select a Service. Click the Lookup button to search for a record.
11. In the Start time and End time lists, set the time when the facility or equipment is not available, and then click OK.
12. Click OK, to close the Work Day dialog box.
13. Click Save or Save and Close.

**Note**
- You can set up service restrictions in your own work schedule.
- All of the options may not be available to you for selecting how much of the schedule you want to edit. The available options are based on the schedules that are already set up.
Find the next available time before creating a service activity

Avoid conflicts while scheduling services by finding the time the resources are available beforehand.

1. Go to Service > Service Calendar.
2. Click Schedule.
3. On the Schedule Service Activity form, type or change information in the text boxes. Hovertips provide hints about what to enter.
   - Under Requested Time, select criteria for the times you want:
     - To search for a time on a specific date, in Start Date, select Specific Date, and then enter the date you want.
     - To search within a range of dates, select Range of Dates, and then enter the On or After and On or Before dates. You can also select specific days of the week.
     - You can also search for times based on dates relative to the current date, such as Today, Tomorrow, This Week, Next Week, or Next Month.
     - Similarly, to search within specific range of time, in Start Time, select Specific Time, Range of Times, or Morning, Evening, Afternoon.
     - Do not clear the Use Default Duration check box and change the duration unless you want to schedule more time than the default duration of the service. The maximum duration of a service activity is 10 days.
4. Click Find Available Times. The next available times are shown.
5. Under Available Times, select the time for which you want to schedule the service activity, and then click Schedule.
   The Schedule Service Activity form closes, and Microsoft Dynamics 365 fills in the information from the selected time in the Service Activity form.
6. Type or modify information in other text boxes, as required. Hovertips provide hints about what to enter.
7. When you're ready to save your data, click Save.
   The service activity appears as a color block on the Service calendar.

Tip
If you want to find an available time without any time restriction, do not specify any criteria under Requested Time, and click Find Available Times.
Create a service activity without checking for conflicts

Make sure you provide timely and efficient service to your customers by creating a service activity that defines who will perform the service and when. In Microsoft Dynamics 365, a service activity uses one or more resources to perform a service at a specific time and place. You can create a service activity by finding the next available times of resources for a service or simply without checking for conflicts.

You can force a service activity into a time slot to squeeze another service activity into the leftover time from a previous service activity.

If you save a service activity without finding available times in the schedule, then Microsoft Dynamics 365 displays the service activity in the schedule without checking for conflicts.

One reason to force a service activity into a time slot is to squeeze another service activity into the leftover time from a previous service activity.

1. Make sure you have the Scheduler security role or equivalent permissions in Microsoft Dynamics 365.
2. Go to Service > Service Calendar.
3. On the command bar, click Service Activity.
4. On the Service Activity form, type or change information in the text boxes.
   Hovertips provide hints on what to enter.
5. When you're ready to save your data, click Save.

Tip
You can record a customer's preferences for a specific time, day, service, facility, equipment, and customer service representative in the customer record on the Administration tab. As you are scheduling a service activity, the customer’s preference is displayed in the Form Assistant pane.

Note
- If at any time before you save this service activity you want to search the schedule for an available time, you can click Schedule in the Actions group to open the Schedule Service Activity dialog box.
- To check the schedule for conflicts, in Service Calendar, in the Actions group, click Conflicts.

Define support terms for customers by using contracts

Effectively track the terms and conditions of support you’ll provide to customers for the products they’ve purchased. In Microsoft Dynamics 365, contracts define information like the duration of the contract,
how many case incidents or minutes of service the customer has purchased, and what hours and days of the week the service or support coverage is available.

Create contracts

You can create new contracts based on contract templates. These define some information, such as allotment types, before you actually write a contract. You can create contracts only for existing accounts and contacts.

A contract has the status of draft until it is invoiced. Each new contract is assigned a unique ID that cannot be used for another contract, unless the contract is being renewed. When renewing a contract, the contract is saved as a draft with an ID that corresponds to the original contract.

Invoice and activate a contract

After a contract has at least one contract line and a billing address, you can mark the contract status as invoiced. Changing the status implies that you have accepted the contract.

Microsoft Dynamics 365 does not automatically invoice the customer or create an invoice record unless your business has integrated Microsoft Dynamics 365 with a Microsoft BackOffice product.

The contract status is invoiced until the start date has passed. Then, the status changes to active. You cannot delete a contract with an invoiced or active status.

Renew a contract

After passing the end date of the contract, the contract is expired and cases cannot be opened against it. To open a new case against the contract, renew the contract.

When you renew a contract, a draft copy of the contract is created with the same ID number as the original, expired contract. You can make modifications to the new draft contract, including adding or modifying contract lines. You have the option of including contract lines that were canceled from the original contract. After the original contract expires, invoice and activate the renewed contract.

A renewed contract has the same ID number as the original contract, reflecting the renewal action in the contract’s history. The start date is automatically set to the day after the existing contract expires. While Microsoft Dynamics 365 gives the renewed contract the same duration as the original contract automatically, you can change the duration manually.

Create or edit a contract

Use contracts and contract lines in Microsoft Dynamics 365 to define accurate terms and conditions for the support or services to be provided to your customers.

Create a contract

Note

Although it is possible, creating a contract from an account is not recommended. The contract does not associate with the account correctly and allotments are not recorded.
1. Go to Service > Contracts.
2. Click +New.
3. In the Select Template dialog box, select a template to base the new contract on.
4. Type or modify information in the text boxes.
   Hover tips provide hints on what to enter.
   a. In the Header section, enter the details of a contract, such as contract name, customer, and contract start and end date.
      When you save the contract, Microsoft Dynamics 365 automatically assigns the Contract ID and calculates the duration, in days, based on the contract start and end dates.
   b. In the Contract Type section, enter the discount and service level of a contract.
      Discounts for contract lines are given the same discount type that you select here. Service levels are defined by your business’s guidelines.
   c. In the History section, the following fields are filled automatically:
      • Originating Contract: This is set when you renew an existing contract.
      • Contract Template: This is set based on what you select in the Select Template dialog box.
      • Owner
   d. In the Billing Information section, Microsoft Dynamics 365 automatically completes most of the fields when the fields in the Header section are entered; however, you can change or enter the information as needed. Bill To Address is required to change the status of the contract to invoiced.
5. To add activities or notes, click Activities or Notes. More information: Add a phone call, task, email, or appointment activity to a case or record

**Note**
- The contract becomes active when it is invoiced and the start date is reached.
- You can edit an existing draft contract, but not invoiced, active, expired, canceled, or on-hold contracts.
- The default days and hours of service are defined in the contract template. To change the days and hours of service, open the contract, and on the command bar, click Set Calendar.

**Add a contract line to a contract**
Use contract lines to define specific dates, the product covered, and how many cases or total minutes of allotted support are provided. You can define several contract lines for each contract; for example, one line for parts and another for maintenance.
1. In the contract record, in the **Contract Lines** section, click +.
   -OR-
   In the contract record, on the nav bar, click the arrow next to the contract name > Contract Lines, and then click **Add New Contract Lines**.

2. Type or modify information in the text boxes.
   Hovertips provide hints about what to enter
   a. Under **General**, enter details about the contract line item, such as the line item name and the product that is eligible for service under the contract.
      The start date and end date for the line item is automatically filled based on the contract dates; however, you can change the dates as needed.
   b. Under **Pricing**, type or modify information about the pricing of the contract, such as the quantity of product or service, total price, and discount.
   c. Under **Administration**, the customer field is automatically populated with the contract's customer. You can change it if required. Enter the serial number of a product.
   d. Under **Allotment Details**, type or modify information about the allotment, such as the total allotment, and the used and remaining allotments.
      The contract template determines the type of allotment (cases or minutes). As cases are opened against this contract, Microsoft Dynamics 365 displays the allotments used in the **Allotments Used** box.

3. Click **Save**.

4. To add a note, under **Notes**, click **Enter a note**, type the details, and click **Done**.

**Note**
You cannot delete a contract line after it is active; instead, you can cancel it.
You can cancel a contract line only when it is set to Active. By canceling a contract line instead of deleting it, you can reuse the contract lines later if you renew the contract or create a new contract based on it. In the list of contract lines, select the contract line, and on the command bar, click **CANCEL CONTRACT LINE**.

**Invoice a contract**
You must define at least one contract line for the contract before you can change the status of the contract to **invoiced**. You can define several contract lines for each contract; for example, one for parts and another for maintenance.
To invoice a contract, after you add a contract line, on the command bar, click **Invoice Contract**.

**Hold, renew, or release a contract**
If you want to make changes to an active or invoiced contract, you must either cancel it or put it on hold. A canceled contract can be renewed and then edited. When a contract is **on hold**, no cases can be
opened against the contract. For example, you might put a contract on hold if there is an invoicing dispute, and then release the contract when the dispute is resolved.

- To put an invoiced contract on hold, in the contract record, on the command bar, click **Hold Contract**.
- To release the contract that’s on hold, in the contract record, on the command bar, click **Release Hold**.
- To renew a canceled contract, in the contract record, on the command bar, click **Renew Contract**.

**Copyright**

This document is provided "as-is". Information and views expressed in this document, including URL and other Internet Web site references, may change without notice.

Some examples depicted herein are provided for illustration only and are fictitious. No real association or connection is intended or should be inferred.

This document does not provide you with any legal rights to any intellectual property in any Microsoft product. You may copy and use this document for your internal, reference purposes.

The videos and eBooks might be in English only. Also, if you click the links, you may be redirected to a U.S. website whose content is in English.

© 2017 Microsoft. All rights reserved.

Microsoft, Active Directory, Azure, Bing, Cortana, Delve, Dynamics, Excel, Hyper-V, Internet Explorer, Microsoft Dynamics, Microsoft Edge, Microsoft Intune, MSDN, Office 365, OneDrive, OneNote, Outlook, Power BI, PowerPoint, PowerShell, PowerApps, SharePoint, Skype, SQL Server, Visual C#, Visual Studio, Windows, Windows PowerShell, and Windows Server are trademarks of the Microsoft group of companies. All other trademarks are property of their respective owners.